Un bug d’élévation de privilèges corrigé dans Dell SupportAssist

Cybersécurité

Les utilisateurs de Dell SupportAssist devraient patcher leur logiciel immédiatement pour corriger un bug logiciel qui pourrait conduire à l’exécution de code arbitraire, selon une déclaration récente du fabricant de PC.

dell supportassist

Dell SupportAssist est un produit logiciel qui est préinstallé sur la plupart des terminaux Windows. Ce dernier effectue des tâches de diagnostic et rationalise la création de tickets support concernant les machines Dell en renvoyant les données nécessaires aux opérateurs. Il peut même offrir une maintenance prédictive aux utilisateurs disposant de comptes premium, les avertissant des composants qui sont susceptibles de présenter une défaillance.

Selon un avis émis par Dell, une vulnérabilité dans le programme permettrait à un utilisateur à faible privilège, authentifié localement, de forcer les binaires du programme Dell SupportAssist à charger des bibliothèques de liens dynamiques (DLL : Dynamic-Link Libraries) arbitraires. Les DLL sont des fichiers exécutables qui peuvent contenir des données ainsi que d’autres ressources, et ils sont souvent utilisés comme moyen pour décomposer les applications en sous-parties modulaires.

En forçant le logiciel Dell SupportAssist à exécuter une DLL, un attaquant pourrait la faire s’exécuter avec les privilèges de l’application Dell, en lançant efficacement une attaque par élévation de privilèges.

La faille qui permet à l’attaquant d’exécuter une DLL est une vulnérabilité de chemin de recherche non contrôlé (uncontrolled search path vulnerability). Ces bugs permettent à des acteurs malveillants de manipuler les chemins de fichiers, rendant ainsi leurs fichiers malveillants exécutables par le système cible.

La vulnérabilité affecte les versions Dell SupportAssist remontant à la version 2.0, mais Dell a résolu le problème dans les dernières versions de son logiciel. Pour les PC professionnels, la version 2.1.4 contient le correctif. Pour les ordinateurs personnels, il s’agit de la version 3.4.1.

La bonne nouvelle est que pour certains utilisateurs, le problème se résoudra de lui-même grâce à la fonction de mise à jour automatique de l’application Dell SupportAssist. Si cette option est activée, SupportAssist effectuera automatiquement une mise à niveau vers la dernière version.

Les utilisateurs qui n’ont pas activé la fonction de mise à jour automatique peuvent installer le correctif en ouvrant le logiciel, en cliquant sur l’icône représentant une roue dentée, en haut à droite et en cliquant sur “À propos de SupportAssist”. Le programme vérifiera ensuite si une nouvelle version est disponible. S’il en trouve une, il affichera un lien “Mettre à jour maintenant” sur lequel vous pourrez cliquer.

La vulnérabilité a été désignée par CVE-2020-5316, qui n’a pas encore été mise à jour au moment de la rédaction de cet article.

Il ne s’agit pas de la première vulnérabilité de chemin non contrôlé à laquelle Dell a été confronté. L’entreprise a été victime d’une faille similaire dans le composant PC Doctor de SupportAssist en juin 2019.

Dernier podcast Sophos-Naked Security


Billet inspiré de Dell fixes privilege elevation bug in support software, sur Sophos nakedsecurity.

Leave a Reply

Your email address will not be published.