Apple por fin soluciona la vulnerabilidad KRACK en los iPhone

ActualidadAppleiPhonevulnerabilidad

¿Te acuerdas de KRACK, la abreviatura de Key Reinstallation Attack (ataque de reinstalación de claves)?

Hace dos meses estaba en todos los medios ya que, además de tener un nombre impactante, suponía una debilidad en el cifrado WPA, el protocolo que emplean la mayoría de las redes wifi.

Resumiendo, KRACK implica engañar a un punto de acceso enviado los dos primeros paquetes de una sesión mezclado con la misma clave de cifrado, de manera que si conocías el contenido de un paquete, podías adivinar el del otro.

KRACK no supone el fin del mundo que conocemos, de hecho afirmábamos que las redes wifi aún eran seguras, pero valía la pena parchear la vulnerabilidad ya que una conexión segura no debe filtrar ningún dato.

Apple, como otras empresas, proporcionó una actualización rápidamente, de la que informamos en noviembre de 2017, pero tenía el inconveniente de que no era para todos los modelos:

Según la documentación oficial de Apple, el parche para KRACK solo afecta a iPhone 7s, iPad Pro 9.7 (principios de 2016) y posteriores.

No sabemos porque el parche para KRACK solo está disponible para los iDispositivos más recientes, es posible que aún estén trabajo en la solución para los dispositivos más antiguos o quizás Apple decidiera que esas versiones antiguas no son vulnerables a KRACK.

Sea cual fuera la razón, si eres un usuarios pre iPhone 7, mantente atento por si aparece una actualización.

Bien, la espera ha terminado ya que en la última actualización de Apple incluye iOS 11.2 y esa oficialmente incorpora parches para KRACK para dispositivos que no aparecían en la primera:

Disponible para: iPhone 6s, iPhone 6s Plus, iPhone 6, iPhone 6 Plus, iPhone SE, iPhone 5s, 12.9-pulgadas iPad Pro 1ª generación, iPad Air 2, iPad Air, iPad 5ª generación, iPad mini 4, iPad mini 3, iPad mini 2, y iPod touch 6ª generación.

Otras muchas vulnerabilidades se han solucionado con la actualización iOS 11.2, incluyendo cuatro descritas como que pueden “ejecutar código arbitrario con privilegios kernel”, lo que implicaría que podrían realizar un jailbreak y tomar el control.

También existe una actualización para macOS, la High Sierra 10.13.2, con tres vulnerabilidades que pueden “ejecutar código arbitrario con privilegios kernel” solucionadas para los usuarios de Mac.

Como siempre os recomendamos que actualicéis vuestros dispositivos lo antes posible.

 

Para manteneros al día de las últimas amenazas haceros fans de nuestra página de Facebook o síguenos en Twitter para intercambiar experiencias en torno al mundo de la seguridad. Si deseas recibir nuestro boletín de seguridad en tu correo electrónico, suscríbete en la siguiente aplicación:

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s