[High] New Up2Date 4.017

Networkup2date

Urgency: HIGH (low, Middle, HIGH)
Size: 14.8MB (14,805,335 bytes)
md5sum: 03ec527ef9dde9b8e9b04d4951c1629a

Urgency: HIGH (low, Middle, HIGH)
Size: 14.8MB (14,805,335 bytes)
md5sum: 03ec527ef9dde9b8e9b04d4951c1629a

After updating from 4.015 or earlier to 4.017, a new kernel (2.4.22) is used for enhanced hardware features and drivers. This new kernel has new ACPI/APIC handling and may conflict with faulty ACPI BIOS implementations. By default we did not change any ACPI/APIC settings, which resulted in full ACPI/APIC support for users having started with a 4.000 and APIC support (without ACPI) for users having started with a 4.008 ISO installation. 

In case you encounter a problem with 4.017 Up2Date when booting up the system (NICs/controllers not recognized/working), please try the following:

  • On the LILO boot prompt, type: "default noapic"
  • Boot up and check your system
  • In case this did not help, type: "default noapic acpi=off"
  • Boot up and check your system
  • Add the needed parameters to the append line in /emergency/boot/etc/lilo.conf
  • Call: "lilo -r /emergency/boot"

We republished the Up2Date 4.017, making sure everybody has both parameters in his configuration file for compatibility reasons. In case you want to use  ACPI/APIC either use 4.017 ISO or remove the parameters mentioned above in the lilo config file. 

In case you still have problems with ACPI/APIC please check for a newer BIOS version or try disabling ACPI/APIC in the BIOS. This new version of Up2Date 4.017 will automatically replace prefetched but not applied prior version of the package. After fetching this Up2Date 4.017 again you will receive an additional notification by email.

If you did not encounter any problems with the prior version there is no need to reapply the Up2Date 4.017.

Up2Date 4.017

Remarks

  • Required previous version is 4.016
  • Existing configuration will not be changed
  • !!! ATTENTION – FIREWALL WILL REBOOT AFTER UP2DATE !!!
    !!! Astaro recommends always to test Up2Date packages with a new kernel
    and reboot on non-production systems first. !!!

New/Changed/Improved

  • New kernel for supporting new hardware
  • Extended PCMCIA card support (Prism 2/2.5/3)
  • Added more ACPI functions – ASL will power off after a shutdown
  • Added DMA support for speeding up newer harddisks
  • Fixed kernel vulnerability (CAN-2003-0961)

Bugfix

(please refer to the known issue list on http://docs.astaro.org)
ID718 USB keyboards may not work after installation
ID690 Only Prism 2 PCMCIA cards supported
ID676 LDAP Base DN is deleted when creating a new user
ID672 Forward to postmaster does not work for virus-emails
ID655 Portscan Notification not working
ID625 DMA mode for harddisks not available
ID603 PPTP sessions through ASL may fail with error 619
ID598 Incoming PPTP connections may fail

Download Information

All Up2Dates are GNUPG-signed! The Astaro Up2Date technology makes it easy to upgrade your installed Astaro Security Linux to the latest version. There are three ways to apply an Up2Date package to the system:

  1. Log on to WebAdmin, navigate to "System -> Up2Date Service" and start a "Update now" in "System Up2Date. An extra browser window will show the progress of the Up2Date process and the System Administrator will receive a notification email once the Up2Date process has finished successfully.
  2. Log on to WebAdmin, navigate to "System -> Up2Date Service" and enable "Prefetch Up2dates". The System Administrator will receive a Notification email after an Up2Date package has been succesfully fetched and can install the Up2Date by clicking "[install]" on the now available menu item "Unapplied Up2Dates". An extra browser window will show the progress of the Up2Date installation and the System administrator will receive a notification email once the Up2Date process has finished successfully.
  3. Download the Up2Date package from our HTTP or FTP Server:
    HTTP: Astaro USAstaro GermanyAustralian MirrorAustria MirrorJapanese Mirror
    FTP: Astaro USAstaro GermanyAustralian MirrorAustria MirrorJapanese Mirror
    Log on to WebAdmin, navigate to "System -> Up2Date Service", start "Import from file" and import the downloaded Up2Date package. After a successful upload click "[install]" on the now available menu item "Unapplied Up2Dates". An extra browser window will show the progress of the Up2Date installation and the System Administrator will receive a notification email once the Up2Date process has finished successfully.

To install Astaro Security Linux, you need the installation ISO image, available on our download page.
 

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.